Network connection problem reaching certain pages

This has been asked before and I have found quite many answers that have not worked so far for me.

The problem is that some sites do not load at all and some videos on Udemy do not play. Let me explain.

I have been going through some courses on Udemy, most of the courses are for my hobbies. I have noticed that some videos do work, but other do not. I went through long and boring support ticket. That resulted in them saying that they didn’t support Linux web browsers…
Then there are sites like when I am trying to log into my work mail, which is Microsoft Outlook. The log in site does not show up, in stead I get black canvas prompting me that the server could be down, I could be behind VPN (which I do not use) or I could be offline.
This also true for few local sites, such as

I have tried clearing cache, enabling/disabling drm and hardware acceleration.
I have tried to install “missing” ffmpeg codecs (can’t find the correct command for now, will look better).
Tried installing MPV player, a solution I found on the Arch forum (which got Udemy working until next restart).
I have tried installing Google-Chrome and logging in that way, without using any privacy extension, with same results.

For my curiosity I installed Fedora on GNOME-boxes, logged into my Firefox account, which sets up all my extensions and tried Udemy, and Outlook. The results is that on Fedora everything works.

I am at a loss now, there are bunch of threads for “Udemy videos not playing on Linux”, most of these are resolved with clearing cache, toggling drm - hardware acceleration on/off or installing some libavcodec package or not solved at all.

it all depends on your hardware, but this wiki should help:

Thank you for this link, didn’t know about it.

However, my browser is still not playing these videos and these few sites are not loading after adding drivers for AMD, changing gfx.webrender.all and meda.ffmpeg.vaapi.enabled to true. This is too hard at the moment.

I honestly cannot find any settings within FF on EOS and Fedora that are different, but for some reason I am not having this problem on Fedora… :confused:

Hardware acceleration wiki did not help, so I have no idea what to check next

Do you have an URL to a non-working sample video?

Yes I do
does not work (one of quite many).

I just found out that Fedora uses mesa driver for webGL 1 redering whle I am using AMD.

Oh, I mean public URL. :wink:

Also it can’t be that complicated. FF comes with ffmpeg build-in and should play everything out of the box if isn’t DRMed. And we established that it works on other systems and you turned on DRM in the FF settings.

All the settings are the same, but somehow DMR content is not playing for me on Udemy.

I do not have public video. However, does not display for me, nor

Both only display black content suggesting that I could be:

  1. Offline
  2. Behind VPN (I don’t use VPN)
  3. Server might be down (which is not, because I can load these sites using different computers).

So is it problem on this system or FF only? Does it work on the same installation if you use a different browser like Chromium?

In the console if you do a curl -LI "" what do you see?

Using different browser does not affect the outcome. This seems to only “affect” this installation

curl -LI ""
curl: (6) Could not resolve host:

Just so you see, using Fedora which runs within GNOME boxes gives this results (sorry, only fig, but it will have to do)

OK. So it can’t find the server on the internet. The gnome-box screenshot is what is should look like.

Are the network settings OK, esp. the DNS server? Is there a difference compared to gnome-box? What’s the output of dig

I don’t know how to change DNS settings, never have needed to. Will check now, but it should be the same.

[olividir@ProX-AMD5 ~]$ dig

; <<>> DiG 9.18.19 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30405
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 7, ADDITIONAL: 13

;			IN	A


is.			5038	IN	NS
is.			5038	IN	NS
is.			5038	IN	NS
is.			5038	IN	NS
is.			5038	IN	NS
is.			5038	IN	NS
is.			5038	IN	NS

;; ADDITIONAL SECTION:		83997	IN	A		83997	IN	A		69068	IN	A		76238	IN	A	9685	IN	A 67956 IN	A 82867 IN	A		59447	IN	AAAA	2001:500:14:6116:ad::1		54134	IN	AAAA	2001:67c:1010:14::53		10267	IN	AAAA	2001:678:20::41		2966	IN	AAAA	2001:6b0:7::2	9685	IN	AAAA	2a00:c88:10:16::20 10727 IN	AAAA	2001:67c:6c:56::10

;; Query time: 3 msec
;; WHEN: Sun Nov 12 18:37:11 GMT 2023
;; MSG SIZE  rcvd: 501

Not sure if this is what you are looking for regarding DNS server:

[olividir@ProX-AMD5 ~]$ cat /etc/resolv.conf 
# Generated by NetworkManager

The one from Boxes is

options edns0 trust-ad
search .

Why does my nameserver not have options edns0 trust-ad?

The dig output looks OK. I’m not a network guy, so this goes somewhat above my paygrade too now. I don’t think that options edns0 trust-ad is important though.

But it seems that there’s something wrong with the network settings. Curl should be able to pull the URL like the gnome-box did, and FF is just another victim of whatever is wrong here.

Maybe curl -LI --verbose hints to a cause.

This is way over my understanding. Have never changed any settings for server.

[olividir@ProX-AMD5 ~]$ curl -LI --verbose
*   Trying
* Connected to ( port 80
> HEAD / HTTP/1.1
> Host:
> User-Agent: curl/8.4.0
> Accept: */*
< HTTP/1.1 302 Moved Temporarily
HTTP/1.1 302 Moved Temporarily
< Server: nginx
Server: nginx
< Date: Sun, 12 Nov 2023 18:54:08 GMT
Date: Sun, 12 Nov 2023 18:54:08 GMT
< Content-Type: text/html
Content-Type: text/html
< Content-Length: 138
Content-Length: 138
< Connection: keep-alive
Connection: keep-alive
< Location:

* Connection #0 to host left intact
* Clear auth, redirects to port from 80 to 443
* Issue another request to this URL: ''
* Could not resolve host:
* Closing connection
curl: (6) Could not resolve host:

Nothing more there. If you go to the system’s network settings and just add “” (google) as DNS server, can you reach hekla is then?

Do you remember where I do that?

Good question! :smiley:

I never ran an Arch server. And whenever I have to do it on the desktop - which rarely happens - I use the KDE Plasma settings app.

Oh boy :nerd_face: been reading about it, but so far Arch wiki has been taking me in the wrong direction

Maybe scratch all this and start a new thread with “Network connection problem reaching certain pages”. Just to attract more educated users who skip on a “Firefox codecs” thread.

Done and done.

In my defense, I thought I was missing plugins.