Nemo hogging CPU resources


I have two laptops and, yesterday, both started really labouring.

I checked the system monitor on the Dell Inspiron 153000 and found that one or the other of the four cores was constantly running at 100% or pretty near. The Processes tab showed that the culprit was nemo-desktop. This was happening constantly, even when I was not using Nemo at all.

I then checked my other laptop, an eight-year-old Novatech, and found the same thing happening there; though that one has only two cores, and nemo-desktop was pulling 50% of total resources. What’s more, for a short while yesterday evening the Processes tab was showing nemo itself pulling almost as much as nemo-desktop, so that the Novatech was getting really slow.

My first thought was to remove Nemo, but when I attempted that on the Dell it appeared to be too integrated into Cinnamon to do.

Can anyone tell me what is going on?

After fruitless hours of tinkering and online searching yesterday, I gave up on the Dell, wiped the drive, and installed EndeavourOS GNOME. However, EndeavourOS Cinnamon was the best set-up I’ve tried yet, so I’m a bit cheesed-off about it all. Help?

Are you using a custom theme?
Because the only time I have experienced something remotely similar was when a GTK theme wasn’t fully compatible with Xfce, and it caused my CPU to go bonkers trying to apply an infinity size texture to the panel.

(Gnome usually don’t have these problems since it’s… Gnome, and lack a lot of the themeable elements of other DEs).


No, no custom theme. You gave me an idea, though.

I’ve just been on the Novatech, where I still have Cinnamon and this problem. I use Variety to rotate a batch of desktop backgrounds. So I tried uninstalling Variety. That didn’t do anything immediately, neither did removing its .config folder. Then I went into Startup Applications to find that it was still showing Variety and with it switched on–I switched off there and things immediately dropped to normal levels in System Monitor.

So it seemed that Nemo doesn’t like Variety. The trouble with that is that I then reinstalled Variety and set it back up, and the problem did not come back.

I think I’ll reinstall Cinnamon on the Dell and see how it goes.


Nemo controls also the backgrounds of the wallpaper. If its going back yu can tenry ti disable cinnamon to controll the deskwall

1 Like

That’s weird. I didn’t know that. Thank you.

Oh well, if the problem comes back, I can easily do without Variety.

Actually I think all GTK based environments from Gnome to LXDE and any in between are coded so that the file manager handles the desktop.

If you think about the desktop just being another folder it’s easier to wrap your mind around.

That’s why it’s always a good idea to leave the built in file manager even if you replace it, say you want to use Nemo instead of Thunar in Xfce.

1 Like

You cab try y

To disable it in dconf-editor

Thanks, but I like Nemo, I’d rather go without Variety.

1 Like