Need help with "Linux failed to load Kernel Modules" Error

Good morning,
I just updated my linux-system and now it won’t let me boot anymore. It will first display some text and then the screen goes black with a cursor at the top left corner. Sadly I do not know where I can get the information of what exactly went wrong.
The error message I found by quickly reading the scrolling text before the blackscreen.
The idea of disabling nouveau I found by googling and using journalctl -b the only red (yes, I’m inexperienced) error message was nouveau “unknown chipset”.

I tried so far to chroot into the system and reupdate all pacman packages which didn’t fix the problem.
Also tried to deactivate the nouveau driver in GRUB though I’m not sure if that worked or not. At least booting wasn’t possible afterwards too.
Using the new nvidia-inst also didn’t help.

I read that for some people using ibt=off in the grub worked but for me it didn’t. Also I’m currently using Kernel 5.13 which shouldn’t have the ibt-option in the first place.

Thanks for your help in advance.

1 Like

Using kernel 5.15 enables you to boot in or not?

1 Like

Sorry for the late reply.

As far as I am aware using paru -Syu also updates the Kernel which did not happen.
The tool akm sadly does not open during chroot. I might be doing something wrong though.

uname -r results in 5.13.12-arch1-1

while pacman -Q | grep linux shows me only versions above 6.x like linux 6.2.2.arch1-1

Is there another way to update the kernel that I’m not aware of?

1 Like


pacman -S linux linux-headers linux-lts linux-lts-headers
1 Like

I did that.
Apparently I had the same drivers installed so it just replaced them with the same ones.

It did not change the results though. Using ibt=off made it boot now.
I guess something went wrong when updating more than just the kernel packages.

Thank you guys very much <3

To mark a comprehensive answer as the solution:

In combination with setting ibt=off in grub did the trick.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.