Need help making worm work after installing endeavouros

I installed endeavouros a while ago and i have now decided i want to switch to worm for my wm

but when ever i try to start it it just gives a black screen
extra info

i installed it through pacman and i have a rc file and a sxhkdrc file in my config folder
and i have tried starting it through my display manager and startx

i have a nvidia gpu (gtx 1080 Proprietary drivers)

Is rc in ~/.config/worm and is it executable? (chmod +x ~/.config/worm/rc, if it’s a script it should have shebang like #!/bin/bash)

Is sxhkdrc in ~/.config/sxhkdrc?

i did all those steps and still black screen

Can you post your ~/.config/worm/rc? What happens if you try to just run worm from your current WM?

my ~/.config/worm/rc is just the example one from github

and when execute worm from terminal it give me

15:39:30 | INFO | wm.nim:35 | Opened display
X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  2 (X_ChangeWindowAttributes)
  Serial number of failed request:  23
  Current serial number in output stream:  24

so do you have any idea why this is happening?

ok, that is pretty expected. actually you should get a black screen, because (which I didn’t write) sets the wallpaper using nitrogen --restore, you can install/set up nitrogen or use something like feh. Also sxhkdrc in that case is in ~/.config/worm/sxhkdrc, not ~/.config/sxhkd/sxhkdrc; and you also need to have that polybar configuration to start the polybar (or make your own / use another bar.)

1 Like

oh okay also where are the defaults endeavouros uses found?

1 Like

what Desktop Manager are you using?

I have found that lightdm with lightdm-gtk-greeter works well while lightdm-slick-greeter not so much.


1 Like

oh no i probably should marked this as solved bit yeah codic12 solution was correct it nitrogen not working resulting in no wallpaper should have realized this but im not very smart


Go to @codic12 's post, click on the three horizontal dots next to Reply.
then click on “Solutions”
This will mark this Topic as solved, and put codec12’s post in the Original Post.
This allows anyone having the same problem look at this Topic’s solution right from the git go and see if it applies to their situation.


1 Like

no, there should really be a description in the README, I will go add one. thanks for bringing this to my attention and glad your issue is solved!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.