Need a favour: Trying to get NetX android app SSH to work

Could someone test for me?

Install:

Set up SSH and try and connect to Endeavour. I keep getting “unknown error” am talking to the Dev over email.

I should note JuiceSSH works fine.

Steve

My settings (in case it is an insufficient caffeine error!):

systemctl status sshd
Failed to execute 'pager', using next fallback pager: Permission denied
● sshd.service - OpenSSH Daemon
     Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: disabled)
     Active: active (running) since Thu 2021-04-01 20:54:16 BST; 15h ago
   Main PID: 666 (sshd)
      Tasks: 1 (limit: 19088)
     Memory: 4.2M
        CPU: 780ms
     CGroup: /system.slice/sshd.service
             └─666 sshd: /usr/bin/sshd -D [listener] 0 of 10-100 startups

Apr 02 11:54:05 xircon-w6567sz sshd[1027797]: ssh_dispatch_run_fatal: Connection from 192.168.0.19 port 48662: DH GEX group out of range [preauth]
Apr 02 11:54:10 xircon-w6567sz sshd[1027813]: ssh_dispatch_run_fatal: Connection from 192.168.0.19 port 48664: DH GEX group out of range [preauth]
Apr 02 12:13:33 xircon-w6567sz sshd[1043447]: ssh_dispatch_run_fatal: Connection from 192.168.0.16 port 34696: DH GEX group out of range [preauth]
Apr 02 12:13:38 xircon-w6567sz sshd[1043549]: ssh_dispatch_run_fatal: Connection from 192.168.0.16 port 34700: DH GEX group out of range [preauth]
Apr 02 12:13:43 xircon-w6567sz sshd[1043553]: ssh_dispatch_run_fatal: Connection from 192.168.0.16 port 34702: DH GEX group out of range [preauth]
Apr 02 12:13:48 xircon-w6567sz sshd[1043654]: ssh_dispatch_run_fatal: Connection from 192.168.0.16 port 34704: DH GEX group out of range [preauth]
Apr 02 12:29:05 xircon-w6567sz sshd[1058236]: pam_systemd_home(sshd:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Apr 02 12:29:05 xircon-w6567sz sshd[1058236]: Accepted password for xircon from 192.168.0.16 port 34962 ssh2
Apr 02 12:29:05 xircon-w6567sz sshd[1058236]: pam_unix(sshd:session): session opened for user xircon(uid=1000) by (uid=0)
Apr 02 12:29:05 xircon-w6567sz sshd[1058236]: pam_env(sshd:session): deprecated reading of user environment enabled

Some errors here though…

I have it working but what do i do with it?

[ricklinux@eos-kde ~]$ systemctl status sshd
● sshd.service - OpenSSH Daemon
     Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-02 11:17:55 EDT; 3s ago
   Main PID: 28264 (sshd)
      Tasks: 1 (limit: 38415)
     Memory: 1.8M
        CPU: 4ms
     CGroup: /system.slice/sshd.service
             └─28264 sshd: /usr/bin/sshd -D [listener] 0 of 10-100 startups

Apr 02 11:17:55 eos-kde systemd[1]: Started OpenSSH Daemon.
Apr 02 11:17:55 eos-kde sshd[28264]: Server listening on 0.0.0.0 port 22.
Apr 02 11:17:55 eos-kde sshd[28264]: Server listening on :: port 22.
[ricklinux@eos-kde ~]$

I don’t have it set up. :turtle:

SSH into your machine, for me it keeps saying unknown error.

I will post a screen shot of JuiceSSH which is working, hang on :smiley:

This is a working session, you can run (text based) commands, it is handy to have if things go wrong.

I have never used ssh so i can try if you explain it.

OK, here goes, lets use Juice.

  • Install juice to your android phone.
  • Create a new connection, enter the IP of your computer, username etc, leave the port as 22.
  • Click save (top right, there is a tick).
    Then click the connection you should now have a terminal running with a prompt on your phone, type ls and it will list the directory on your computer.

I have juice installed. I put ip address port user name. What about groups?

Ignore groups for the time being, they appear to be for organisational purposes.

Okay that was easy. Now what can i do?

That’s cool…i just updated and reboot the computer.

Run any terminal command you want. I am now trying to be able to do this from outside my network, so I can contact the computer over the mobile network.

If, for example, an update goes wrong and you end up with a blank screen, you may be able to use this instead of chroot.

Will let you know when I work out how to do it remotely :wink:

I don’t understand the setup on Netx? It seems different.

Yeh, it is different, the dev hasn’t said much, he tried it and it works, I don’t know if I got it wrong, he has the same screenshots.

Can you download files from the computer?

I use KDEConnect for that, but you can:

But I want to run commands remotely, but will look at that later :smiley: :smiley:

1 Like

Worked it out.

  • Give your computer a static address in the router.
  • Create a new service.
  • Forward the port to that IP
  • Setup a new connection using your external IP and port chosen.
  • Disconnect phone from WIFI
  • Connect…

How you do all of this depends on your router, my ISP is Sky and likely to be completely different from yours :smiley:

If the remote computer is set up as a server, you can use ssh and sshfs to automatically connect the client computer to the server’s data partition and have it appear in your file manager at every login. I have a partition /home/don/Server that gets mounted via sshfs at login and the OS now thinks that is a local partition, not a remote partition, and you can now do anything you can do on a local partition.

Pudge
EDIT:

In the above, ‘Server’ is the main server, and ‘enosServer’ is a play around with Arch based server. Both are automatically mounted at login.

2 Likes

TBH, I am bored, playing around on a cold bank holiday :rofl: Lockdown lifted, so my partner has gone for a walk with her sister, so I have no purpose or design to this.

But I can shut my computer down from anywhere (or until the router picks up a new external IP), whoop de doo :smiley:

https://www.noip.com/

I use this for my personal web site that connects to the internet through my ISP’s residential plan (read dynamic web side IP address).

It establishes a URL for my website, then a noip provided service runs in the background and senses when the external IP address changes. It then phones home and the proper adjustments are made so the URL still works. Been using it for 4 or 5 years.

Pudge

Setup, my router actually only supports 3 service, but noip was one.

1 Like