NAS icons cant be clicked in Thunar

Hi All

Absolutely awful at this sort of thing.

Switched from another Arch distro to this one as had read good reviews about it. However, I cannot click on my NAS drives to open them up. The icon is just unresponsive in Thunar.

So it would appear that the system can see the NAS drives, however, it cannot do anything with them.

Where is the best place to start to troubleshoot this please?

depending on what your nas uses for sharing?

And of cause welcome to the forum! :enos:

to check why it could help to open a terminal and watch the journal while try to open the nas shares:
journalctl -f

Hi and thanks for the welcome - and the start

In terms of the what the NAS do, they are my central storage for all the computers in the house, with documents, photos, backups etc on them

I opened a terminal and watched the journal - when i opened thunar and clicked browse network and then clicked on MyBookLive - the journal did not move at all.

I opened firefox and navigated to a random website, and the journal updated at that point.

Not sure that helps much

never was using nas but i would bet thunar needs some package or setup to be able to open the shares… because of that I asked for what the nas is using could be samba or nfs or sftp/ssh

If that is Western Digital MyBook Live it is probably using samba protocol for connection.
Look if you have intalled packages (with pacman -Ss) smbclient, gvfs-smb, udiskie, udisks2
I am not sure which are the correct packages but I have these and I usually don’t have problem connecting drives.

It is also possible you do not have permission to mount the drive (you may need to run thunar as root - this may not be entirely safe/sane thing to do).

1 Like

sudo pacman -S --needed smbclient gvfs-smb udiskie udisks2
will only ask to install if not already installed.…
pacman -Qs package-name will show if package is installed…

Many thanks to all taking a crack at this one - have run the above for all the samba stuff and it did install some stuff - but had made no observable difference alas.

not sure if it means anything but, when i type

ls /etc/samba

I get the return of


is this normal ?

Not sure if it relevant, but back when I used samba I had to start a smb.service (and maybe more) to get it to work. Might be worth a look to see what’s involved…

looking at samba to be honest just terrifies me.

I dont understand it at all and all the guides are written assuming you are familiar with the lingo for it ( could really just use a guide with examples )

having said that - looking on thunar - i can see the NAS drives by clicking browse network ( cant interract with them ) but when I go to windows network icon - i cant see anything at all

It’s a Micro$oft product, that allows a filthy, polluted windoze machine, full of malware and backdoors to connect to your pure, innocent GNU+Linux system. You are perfectly justified in being terrified of it.


You sound a little biased here… :innocent:

This service runs samba so that you can share files on that device to the rest of the network (a.k.a a server). If you want to connect to some other device you will need samba client (smbclient).

Some googling returned this help.

So some commands that may help you determine if samba is really in play here.

/usr/bin/smbclient -L host

host is your NAS (e.g. or my_nas)

/usr/bin/smbclient service <password>

service is what NAS provides listed above by -L option (e.g. smbclient \\\\\\public).

so running the first gives me

Sharename Type Comment
--------- ---- -------
IPC$ IPC IPC Service (My Book Live Network Storage)
Public Disk Public Share
SMB1 disabled – no workgroup available

running the second command gives

[iand@Linux ~]$ /usr/bin/smbclient \\\Public
Can’t load /etc/samba/smb.conf - run testparm to debug it
Password for [WORKGROUP\iand]:
Try “help” to get a list of possible commands.
smb: > help

if that helps

It looks like samba is working on the NAS.
In Thunar can you enter smb:// or smb:// into the navigation bar (where you see your current Path)? Does that connect you to the NAS?

1 Like

Hi All

Again thank you for the assist.

I tried a different approach and installed the Budgie desktop as opposed to the xfce one - and it all just started working ( Never have quite got my head round why this sometimes helps ) point is, I am up and running with Endeavour OS and really pleased with how fast and nimble it is