Nach Update keine Anzeigeeinstellung möglich

Hallo,
nach dem letzten Updaten ist die gesamte Anzeige klein -Schrift, Icons, Screens…
In Einstellungen > Anzeige lässt sich leider nichts mehr einstellen,
steht fix auf 1920*1080, 16:9.
Keine Änderung möglich.
Vielleicht eine Idee?

Hi Ralle,

schwierig zu sagen was das schief gelaufen ist. Ein Paar Infos wären hilfreich um dir weiter zu helfen wie z.B. welche Desktop Umgebung du benutzt, poste am besten die Ausgabe folgender Befehle:

inxi -F
xrandr

wenn du in den Einstellungen nichts ändern kannst, dann schau dir im Home Verzeichnis unter .config die Monitor.conf an, bei mir ist LXQt im Einsatz und da finde ich die Datei unter .config/lxqt/lxqt-config-monitor.conf.

Edit: was wurde denn aktualisiert?

inxi -F
System:
  Host: ralf-20kd001mmd Kernel: 6.3.9-arch1-1 arch: x86_64 bits: 64
    Desktop: Xfce v: 4.18.1 Distro: EndeavourOS
Machine:
  Type: Laptop System: LENOVO product: 20KD001MMD v: ThinkPad A275
    serial: <superuser required>
  Mobo: LENOVO model: 20KD001MMD serial: <superuser required> UEFI: LENOVO
    v: R0NET46W (1.24 ) date: 04/13/2021
Battery:
  ID-1: BAT0 charge: 17.1 Wh (97.2%) condition: 17.6/23.2 Wh (75.7%)
  ID-2: BAT1 charge: 1.0 Wh (5.6%) condition: 17.9/23.5 Wh (76.4%)
    volts: 11.0 min: 11.4
CPU:
  Info: quad core model: AMD PRO A12-8830B R7 10 COMPUTE CORES 4C+6G bits: 64
    type: MT MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1322 min/max: 1300/2500 cores: 1: 1294 2: 1300 3: 1300
    4: 1397
Graphics:
  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] driver: amdgpu v: kernel
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon R7 Graphics (carrizo
    LLVM 15.0.7 DRM 3.52 6.3.9-arch1-1)
Audio:
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Family 15h Audio driver: snd_hda_intel
  API: ALSA v: k6.3.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.71 status: active
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp1s0f0 state: down mac: 54:e1:ad:a2:e8:79
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  IF: wlan0 state: up mac: 38:ba:f8:58:e6:b1
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 476.94 GiB used: 40.09 GiB (8.4%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS512GD9TNG-L5B0B
    size: 476.94 GiB
Partition:
  ID-1: / size: 233.36 GiB used: 40.07 GiB (17.2%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 96 MiB used: 26.5 MiB (27.6%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 4300 fan-2: 4300
Info:
  Processes: 207 Uptime: 54m Memory: available: 7.18 GiB
  used: 1.79 GiB (24.9%) Shell: Bash inxi: 3.3.27

xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 276mm x 155mm
   1920x1080     60.05*+
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)

du hast nur eine Option zur Auswahl, deswegen hast du nicht die Möglichkeit es zu ändern.

1920x1080     60.05*+

bei mir schaut es z.B. so aus:

$ xrandr
Screen 0: minimum 320 x 200, current 5360 x 1440, maximum 16384 x 16384
eDP connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.03*+
HDMI-A-0 connected primary 3440x1440+1920+0 (normal left inverted right x axis y axis) 797mm x 334mm
   3840x2160     60.00    50.00    59.94  
   3440x1440     29.99* 
   2560x1080     60.00    59.94    50.00  
   1720x1440     59.94  
   1920x1080    120.00   119.88    60.00    60.00    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  

da sind mehrere Auflösungen zu Auswahl.

hast du mal Versucht den LTS Kernel zu starten um zu schauen ob das Problem mit dem neuen Arch Linux Standard Kernel zusammenhängt? sollte es so sein, könntest du entweder den LTS benutzen oder nach einem geeignetem Treiber suchen.

Moin,
dass nur eine Einstellung möglich ist, ist bekannt, hatte ich ja auch geschrieben.
Vor dem Update aber, hatte ich ähnlich viele Einstellmöglichkeiten wie du.
Wo ist also der Schalter den man umlegen muss, damit es wieder wie zuvor ist?
zu der Frage was aktualisiert wurde: Das kann ich gar nicht sagen.
Wenn ich das Update angestossen habe, werde ich im Terminal nach dem Passwort gefragt und dann läuft es durch, bis ich aufgefordert werde die Enter-Taste zu drücken und einen Reboot zu machen.

das ist wahrscheinlich ein Treiber (AMDGPU) Problem das hoffentlich demnächst behoben wird.
https://gitlab.freedesktop.org/drm/amd/-/issues/2655

Sollte das Problem umgehen wenn es am aktuellen Kernel liegt.

Und… ich sehe bei beiden hier das selbe… nur eine Auflösung für eDP:
2023-06-27_06-27

Mit dem einzigen Unterschied das @pycrk HDMI angeschlossen hat… und dafür alle Auflösungen die das DIsplay unterstützt angezeigt werden… bei @Rallebiker ist HDMI und DP-0 ungesteckt also werden auch keine Auflösungen angezeigt…

ja eDP ist bei mir der Bildschirm des Notebooks, bin mir nicht sicher ob da überhaupt mal mehrere Auflösungen waren. Aufjedenfall nach den Kernel Update am WE war mein HDMI Bildschirm schwarz, nach einem Wechsel zu LTS und zurück ging es wieder. Allerdings hab ich bei eDP unter LTS auch nur eine Auflösung. Unter dem Link den ich weiter oben gepostet hab, hat jemand einen ähnlichen Fehler im AMDGPU Issue Tracker gepostet, da steht das es in Zukunft behoben wird.

Ok,
danke schon einmal für die Hilfe.
Wenn ihr mir bitte noch sagen/schreiben könntet,
wie ich diesen LTS-Kernel aktivieren, ggf. aber auch wieder deaktivieren kann?
Sonnigen Tag noch!

:sweat_smile:

sudo pacman -Syu linux-lts linux-lts-headers
das installiert kernel und header sollte dann per default gebootet werden.
Solltest du Grub Bootloader verwenden … braucht es noch einen neubau der Konfiguration für Grub:
sudo grub-mkconfig -o /boot/grub/grub.cfg

Und wie de-installieren, so dass wieder der aktuelle läuft?

Den brauchst du nicht deinstallieren. Die Auswahl, welcher Kernel gestartet werden soll, nimmst Du im Grub-Menu vor.

genau wie @swh sagt beide können nebeneinander verwendet werden… du kannst den Kernel als default einstellen den du booten willst.
Oder so das Grub immer den zuletzt gewählten verwendet.
GRUB_DEFAULT=n

wo n die Nummer des Eintrages nach Reienfolge ist wobei 0=1 (erster Eintrag) 1=2 (2. Eintrag) u.s.w.

2023-06-27_17-15

also würde 0 den LTS starten und 2 den standard Kernel…

oder für zueltzt gewählten als default:

GRUB_DEFAULT=saved
GRUB_SAVEDEAULT=true

Also das LTS-Kernel habe ich installiert (genau wie oben vorgegeben),
dabei wurde auch gleich eine Systemaktualisierung automatisch mit angestossen.
Dann noch den Neubau der Grub-Konfiguration laufen lassen (genau wie oben vorgegeben,
dann ein Reboot - und nun habe ich Chaos im Grub-Bootloader.
Da steht jetzt:
EOS Linux, mit Linux Linux -lts
EOS Linux, with Linux Linux lts (fallback initramfs)
EOS Linux, mit Linux Linux
EOS Linux, with Linux Linux (fallback initramfs)
EOS Linux, mit Linux Linux -lts
EOS Linux, with Linux Linux lts (fallback initramfs)
Windows Boot Manager
UEFI Firmware Settings
EOS Linux,
EOS Linux, with Linux Linux (fallback initramfs)
Windows Boot Manager
UEFI Firmware Settings

Also vorweg, am LTS-Kernel liegt es nicht mit der verquerten Anzeige.
Wie bekomme ich jetzt wieder alles weg, so dass nur wie zuvor
EOS Linux
EOS Linux (fallback…)
Windows Boot…
UEFI…
drin steht ?

wird wohl and der etwas überholten /etc/default/grub Vorgabe Datei liegen…

zeig diese mal bitte:

cat /etc/default/grub | eos-sendlog

Oder an einer vorherigen Installation von Grub-Customizer… :skull:

@anon11595408
Ich hatte ja vor längerer Zeit mal angefragt wie die Schrift vom Grub-Startbildschirm zu vergrösseren sei.
Dabei wurde auch der Grub-Customizer aufgeführt, den hatte ich gar nicht mehr auf dem Schirm.
Habe ich jetzt gestartet und es kam die Meldung, das einige Skripte aktualisiert wurden.
Neustart und es ist tatsächlich wieder ok, incl. des LTS-Kernels!
Danke euch schon mal!
Wenn jetzt noch das Grafikproblem von den Entwicklern behoben wird ist alles wieder gut.

Echt gruselig!

Das Benutzen von grub-customizer ist der allerbeste Weg, sich sein System “für immer” zu verkaspern! Irgendwann läuft dann garnix mehr. Nur mal so gesagt.

Hier im Forum gibt es Anleitungen, wie man den wieder los wird, ohne alles neu installieren zu müssen. (“Latürnich” auf Englisch.)

Das Problem liegt allermeist zwischen dem Stuhl und der Tastatur. Viel weniger an den Enwicklern!
(OMG)…

:cold_face:

Ja hab’ ich gefunden -schaun wir mal.

Ja, das ist der einfachste Weg.