My-weather-indcator showing only n/a

for the last week or so my-weather-indcator has shown nothing but n/a for the weather. the time still shows up as being accurate and there. the future forecast as well shows nothing but n/a for everyday in the week. i tried deleting the .config file. i was prompted to put all my settings back in such as the united states system of units, the am/pm settings, my location, etc… i thought that would fix the issue unfortunately it still showing n/a when i reloaded all my settings into the program. i am a loss… any help would be wonderful. i think it maybe just a bug and it will need updating. i hope they fix it soon. i used to use conky i loved it. i had the time for one conky configuration and i had the weather for the other. yahoo no longer does api and it stopped working a long time ago. i would go back to conky but i have yet to find a easy configuration for weather on the internet ever since. maybe i am wrong? IDK i like having a large clock and weather on my desktop it keeps me on track. i also have a large 55 inch tv hooked up to my laptop i love being able to just see this info a quick glance when needed. hehe computers rule… endeavour os is the bomb. haha i love this operating system/distro whatever. it’s been so long since i have used windows i don’t even really know what it’s like anymore other than it is trash. linux rules… oh well hope to hear back from you guys soon. maybe someone does know how to fix this?

Good Day WhitewolfAK47,

Can you run the below command from terminal so we can get your system configuration:

 inxi -b

Additionally can you provide a screen shot of your weather application? Thanks.

The app was just updated today; have you updated it yet?

1 Like

no i shall try thankx LOL

PS: updating now, i am going to reboot and let you know.

1 Like
[fj@whitewolf ~]$  inxi -b
  Host: whitewolf Kernel: 6.1.23-1-lts arch: x86_64 bits: 64 Desktop: Pantheon
    Distro: EndeavourOS
  Type: Convertible System: Dell product: Inspiron 7415 2-in-1 v: 1.4.0
    serial: <superuser required>
  Mobo: Dell model: 09X2G7 v: A01 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 07/12/2021
  ID-1: BAT0 charge: 51.8 Wh (100.0%) condition: 51.8/54.0 Wh (96.0%)
  Info: 6-core AMD Ryzen 5 5500U with Radeon Graphics [MT MCP] speed (MHz):
    avg: 1457 min/max: 1400/4056
  Device-1: AMD Lucienne driver: amdgpu v: kernel
  Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: amdgpu unloaded: modesetting,vesa dri: radeonsi gpu: amdgpu
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.23-1-lts)
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  Local Storage: total: 238.47 GiB used: 136.48 GiB (57.2%)
  Processes: 359 Uptime: 1d 24m Memory: 7.12 GiB used: 4.82 GiB (67.8%)
  Shell: Bash inxi: 3.3.26
[fj@whitewolf ~]$ 

PS: WOW, that is so cool I didn’t even know that command existed. ha, ha

Nice try, no cigar… lol bummer it it is still reading N/A :frowning:

1 Like

What does this return?

pacman -Qi my-weather-indicator

So you are using Patheon Desktop. So which weather app are you using?

I use Gnome, and previously used the OpenWeather extension ( So at somepoint I needed to sign up at for an API key so I could connect to that service to get Weather. After that weather syncing worked for me.

Maybe your App uses openweathermap for weather data.

UPDATE: i was going to try what you said but your not going to believe this. one more update came for my-weather-indicator… after it updated the application will no longer run. it literally does not show up. so i guess that is the end of me seeing the weather on my desktop in Pantheon DE at least (in some aesthetic and large way). i could always switch to gnome like you and get the openweather extension like you or i could go to KDE plasma and i am sure they have a widget there as well but i am probably not going to do that. i love pantheon de to much. for me it just makes sense idkw. wish there was some other way around this like another application altogether i could get on pantheon de though… i can’t complain. i do have other desktop environments like i said i could use a weather application, widget, extension, etc. it’s okay i won’t complain i am sure at some point it will update and resolve itself.

When a weather widget suddenly shows n/a, that means the weather API changed, or stopped allowing unlimited use, it varies as to the cause.

The only real solution to getting desktop weather is to use something like wittr CLI weather tool. Widgets that are going to be distributed to a wide user base require an unlimited weather API, which is almost impossible to find anymore, they are all shutting down, restricting accesses, etc, so the only real solution is to setup your own weather tool on your system, like wittr.

Many weather widgets were first created when weatherunderground had an open API, and unlimited queries to that api, so we didn’t need to worry about issues like that, but then tney got sold, shut down their free api, and that was the end of many weather widgets. xfce weather widget was one of those, I don’t know if they ever figured out a new api to use or not.

1 Like

THANK YOU ~ that all makes good sense to me.

FYI, the latest version of the package was updated to use a different weather service provider, as the previous provider was no longer available for free. See here.

The latest version is working fine, except for the humidity not being displayed:


wow… thank you

PS: it started working again!!!

1 Like

Yes, none of the apis are identical, each differs slightly. And they are dropping fast, every year we’re losing more of them, apple bought one, I think darksky, and closed public access december 2022. weatherbit slashed their daily api use in november 2022. wunderground shut down public free access march 2019. I only know of one true unlimited unrestricted api, but it has other attribution requirements.

Most of them require a private api key to use, which you can’t do with a weather widget, so it has to be an open api. Don’t count on those lasting by the way, they are vanishing quickly.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.