My nfs share folders arent folders anymore

hi all

for some reason my mount in fstab that i have is working to mount all my shares exept one , well it does mount it but the folders are now showing as the “run” icon and the “kind” is “unknown”.

i have tried removing the mount from fstab and restart and then adding again and restart but still it persists … wiered thing is if i type out the share path in my window manager it brings it up as it should no problem but that is if i use smb and not nfs. in my fstab it is all mounted as nfs.

any ideas?

my fstab

#
UUID=6ff6ad6d-f310-4764-873e-89b7884e38ec / ext4 defaults,noatime 0 1
UUID=9d0940fc-7903-40c0-aab0-7ad78aca66bd /mnt/ ext4 rw,auto,user,suid,exec 0 0
192.168.2.154:/export/Music /home/angelus/Music/ nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0
192.168.2.154:/export/Series_End /home/angelus/Series_End/ nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0
192.168.2.154:/export/Series_Running /home/angelus/Series_Running/ nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

example of folder :-/ under /home/angelus/Music/
image

image

image

on my server which has omv on it
drwxrwsr–+ 21 Angelus users 4096 Apr 7 14:53 ‘Bump Collection’

on server
:/export/Music# id Angelus
uid=1001(Angelus) gid=100(users) groups=100(users),4(adm)

on server
/etc/exports: the access control list for filesystems which may be exported
to NFS clients. See exports(5).
/export/Music 192.168.2.150(fsid=1,rw,subtree_check,insecure)
/export/Series_End 192.168.2.150(fsid=2,rw,subtree_check,insecure)
/export/Series_Running 192.168.2.150(fsid=3,rw,subtree_check,insecure)

on server
/proc/fs/nfs/exports
Path Client(Flags) # IPs
/export/Series_Running 192.168.2.150(rw,insecure,root_squash,sync,wdelay,fsid=3,uuid=b7208b93:6e6f44fe:8933789c:94e6c649,sec=1)
/export/Music 192.168.2.150(rw,insecure,root_squash,sync,wdelay,fsid=1,uuid=b7208b93:6e6f44fe:8933789c:94e6c649,sec=1)
/export/Series_End 192.168.2.150(rw,insecure,root_squash,sync,wdelay,fsid=2,uuid=b7208b93:6e6f44fe:8933789c:94e6c649,sec=1)
/export 192.168.2.150(ro,root_squash,sync,wdelay,no_subtree_check,fsid=0,uuid=e6583d44:b94640b2:b8506a1d:a950a134,sec=1)

What were you doing before that happened?

wellllllll i was on the server and fiddling with the user id’s and grp’s but then i put it all back as it was and removed what i had entered. so i had created a user angelus on the server trying to make it the same as the user angelus on the client with the idea that it would then mount or be able to mount with the same permissions as if on the server so i can rename and copy paste stuff onto the server from the client.

but it only effected the music share, the other shares are absolutely fine … it must be a permission thing i just digging to as where

edit:

the permissions are different for music on the client if i compare to the other shares
this is fine
drwxrwsr–+ 788 1001 100 61440 May 4 17:21 Music
drwxrwsr–+ 207 1001 100 12288 Feb 5 12:22 Series_End

but in the music folder the files have root:root and rwx for all

but as root in terminal i cant get into it keeps saying permission denied even as root

Can you access the files from the server?

Also, have you validated that there isn’t any corruption on the disks at the server?

yes i can access on the server , i have been comparing the diff shares and it all looks the same to me.

i hope that there isnt any corruption i got a raid6 setup. but i can access the music share if i type out the path on my client window manager using smb and enter in my password and walla, if i try that with nfs it says mount point does not exist

edit ;

ok i had already installed a “reset perms” application that i used now and it reset all my shares to default perms … and now is all back to how it was

reset perms, reset the permissions to

Changing owner to root:users …
Change directory permissions to 2775 …
Change file permissions to 664 …
Done…

but now i’m back at the issue i was trying to resolve, being i can not cut n paste from client to server, or rename folders and files…etc

all folders and files have permissions of root:user , the user group has id of 100 on the server, so the shares are being mounted with the perms that are on the server. is it right that even if the owner is root that i would still have this issue?

ok took a while but i figured it out :sweat_smile: :grinning: :grin:

so the uid and gid need to be the same on the client and on the server then on the server in the acl set the owner as that uid and the group as that gid that has just been made the same. and then walla the share is mounted as that user and group;

as example;
on client

uid=1010 (test) gid=1011 (test) groups=1011 (test)

on server

uid=1010 (test) gid=1011 (test) groups=1011 (test)

then on the server in the webgui of omv

give “test” user and “test” group rw privileges
and in acl set owner and group to “test” and rwx, and “others” to “none” , that way only “test” has access to that share, so no guest access.

i’m sure there must be a better guide out there somewhere but that is basically what i did, using ssh and also the webgui

well thanks all for the help :100:

Solved, then? If so, please mark the thread as such by marking the post with the solution as, well, the solution.

Oh, also, voilà. Once, I can stfu. Twice? Non.

1 Like

Imgur

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.