My install is borked!

I tried installing libimobiledevice to help a friend with her iPhone. Did not install correctly so I ran yay -Rncs libimobiledevice to remove it all but I did see it removed some needed dependencies. Yikes.

I did run update before I exited, I noticed my Konsole was all white I assume since I blew out some GTK dependencies on accident trying to remove all of libimobiledevice.

Upon reboot, I get the EOS boot choice, but after that, the below screen and I can’t go any further?

Take a look at your /var/log/pacman.log and see what you removed. You may have removed your entire DE.

What is/was your installed DE?

As a side note. There is no problem with using -Rc but using -Rcs requires special care and can remove way more than you intend.

Plasma, so I want to say sddm?
It tells me permission denied trying to acces pacman.log ?

Oof.

That’s definitely a deep clean. As suggested the log will tell you what’s gone. It may be easier to start over though. That’s up to you.

Try reinstalling plasma, that should get you going again.

sudo pacman -Syu plasma

Crap, I installed sddm, GUI ask for password but Enter doesn’t work.
How to I get back to ttt1 so I can install Plasma?

I figured out how to get bqck to tty1 but getting these errors trying to install plasma

Are you connected to a network?

try this

ping -c4 kernel.org

Not sure, I ran sudo pacman -S sddm to install that without issue, tried -S plasma, starts but fails retrieving plasma-workspace-5.24.5.1 same errors as above

“Temporary failure in name resolution”

First check what was removed and if (as suspected) you broke your network (networkmanager) manually install from cache. Choosing important packages first, may bring you the rest sooner.

grep upgraded /var/log/pacman.log | tail -n100 | less wrong filter :face_with_head_bandage:

sudo pacman -U /var/cache/pacman/pkg/<package-file-name-and-version>.pkg.tar.zst

Nice :grin:

Be careful using -Rncs and make sure you read what its removing. -Rncs was definitely not needed but like has been said check your pacman log.

You should be able to recover though, it’ll be a learning experience to do so. If you removed network stuff it’ll get complicated and may require manual configuration.

Stay calm and Think of it as a badge of honor, we’ve all nuked things badly at some point :joy:

Looks like quite a bit for 5/02

I tried withr package listed in the log but errors out

you need to connect to the internet. it’s not connected.

You may find the whole process easier to chroot in first. That way you have some tools and wifi.

1 Like

Incomplete file name.
You should use autocomplete, using tab twice to get existing files correctly.

1 Like

in the pacman log, not seeing network was blown out? Seems to be the plasma GUI and related, mirrorlist etc?

1 Like

I am sorry, I mistakenly gave you the wrong filter. You are looking for removed packages, so use this

grep removed /var/log/pacman.log | tail -n100 | less
2 Likes