My install is a permission mess

I don’t know at which moment I messes up, but my install is an utter permission chaos.

There are several problems. First, I need to dual-boot Windows, not connected to the internet for privacy. Without many details, I can’t get rid of it and need external disk is exFAT. This causes issues: sometimes I get permission denied to paste files inside, sometimes I paste them, but Windows can’t detect them (Windows can), and sometimes pasting files/creating folders is entirely blacked out (don’t confuse with first issue when it isn’t and I still can’t).

But inside my Linux drive it PERSISTS!!! Even with copying among folders of the same drive will still give me permission denied!!! Why? Not special or protected folders but literal desktop folders, I I have desktop photos and desktop music it won’t let me exchange files by random chance.

And both issues are random and out of my control. Sometimes they paste first try. I also tried opening dolphin as sudo and even as sudo it solves nothing because the exact same problems persist.

It’s absolutely desperating and renders my system unusable, what is going on?

exfat doesn’t support POSIX permissions so the permissions are controlled by how you mount it. If you mount it with permissions for your user.

How are you mounting it now?

I used gnome-disk-utility. I set it up to mount automatically at system startup. I did nothing more.

Still, the rest of the system is also affected, even the main partition (with EndeavourOS).

Well, then you are a victim of whatever gnome disk utility decided to do. You should look and see what it did specifically.

We can only help with these things based on specific examples.

Ok, I think I should undo that. How could I keep it mounted between boots? And give myself enough privileges, of course. chown is kinda obscure for me and never got to make it work, not experienced with it.

By adding an entry to /etc/fstab

For an exfat drive, you can use mount options to give yourself rights. The relevant mount options are umask, dmask, fmask, uid and gid. The important part is to set uid and gid to your user.

chown won’t work on exfat. However, a basic understanding of how permissions work in Linux is fairly important to the daily use of your system.

This is a pretty good primer to file permissions on Linux:
https://www.guru99.com/file-permissions.html

1 Like