My IGPU mysteriously turned off twice while simulating for folding@home

The other day I found my PC’s lights running but my monitor off. I thought it had something to do with the OS so I didn’t think much of it. However it happened today, while I was using my system. The common link? Both of those times I was running folding@home on my igpu. Now, I was able to SSH into my system and was a little glad to see that everything software-related was running (even awesomewm). However, when I tried to run xrandr I got Can't open display. Running radeontop I was able to see that my igpu was at 0%. Even sensors couldn’t report my igpu’s temperature. This leads me to believe that my igpu turned off. As a sidenote I tried shutting down the system from SSH using sudo shtudown +0 but my pc’s fans and lights were still running so after some time I had to force a shutdown.
It should also be noted that for the past 3 months or so my screen has been (albeit rarely, once every few hours) going randomly black for ~4 seconds before coming back on (also happens on windows).

CPU: AMD Ryzen 5 3400G
GPU: Vega 11 IGPU
Motherboard: AsRock b450m Steel Legend
Monitor: LG 24MK600M-B (connected with HDMI)
Driver: mesa 21.1.3-1. As for OpenCL I was using an older version (20.40) of opencl-amd (here is the PKGBUILD).

Edit: So I found this thread which is similar (if not the same as) to my problem: