My Experience with the RPi 4 4gb and EnOS

I plan on using a Raspberry Pi for my home server. I will be replacing my current power hog of an AMD FX-6400. I have it all set up with Ubuntu Server. Since I had an extra MicroSD card and some time while I wait for my drive array to arrive, I thought I would give EnOS Arm a try. Despite some minor frustrations, I had a lot of fun getting everything up and running. Here are the problems I had and their fixes.

Problem 1: Samba would not connect to my existing home server. It runs Ubuntu Server and every device in my house, a Windows machine, 2 nVidia Shield TV’s, Raspberry Pi OS on a Raspberry Pi 3, my and my wife’s cell phones and Arch on my laptop, have no problems connecting to it.

Solution: After following both the guide in the EnOS wiki, the Arch wiki, multiple reboots, checking firewall settings, and comparing my settings from my other Linux machines I was still not able to connect. I ended up copying a known working smb.conf from my laptop to the Pi4. After a reboot, I was able to connect without any issues. I looked at both versions of the smb.conf and could not find any differences. In fact, I copied the smb.conf from the Pi 4 and put it on my laptop as a test, and had no problems connecting. So who knows what was going on.

Problem 2: Logitech Unified Receiver issues. Sometimes it would see only my keyboard. Others times just my mouse. Ironically, there were times it would see both. All during the same session!

Solution: Installed libratbag/piper from the repositories and that seemed to fix the issue.

After fixing those 2 issues, I had a working Raspberry Pi 4 with the Mate desktop. I have to say that I am impressed. The DE was snappy and the programs loaded nicely. I had no problems playing back video (1080p H265) over my network. I gave it to my wife to try out, and she liked it. So it got a WAF (Wife Approval Factor) of 10. Which is very rare.

I had fun working through the install and the issues. I am going to play around with it some more and see what happens. Thank you all for your hard work with this project. It was awesome to see Arch running on my favorite “little machine that could.”

5 Likes

What a naming though :rofl:

And logo even better

5 Likes

Arch, being bleeding edge, has samba V4 in the repositories. A lot of distros, including my Fedora Server, are running earlier versions, either V2 or V3. I have also run into problems trying to make different Versions play nice together. I feel your pain.

Pudge

1 Like

My favorite DE for SBCs so far is Budgie desktop, with several modifications.
See here for screenshots

If anyone is interested in the modifications, let me know.

Pudge

1 Like

Interesting. That is one thing I did not check for in my troubleshooting. It is strange how it magically fixed itself. It is something I am going to have to dig deeper on.

It is a pain that seems to happen whenever I delve into networking. From the first time I tried to “network” two computers together using a Null Modem cable back in the day. Whenever I do anything with networking, I know that I am in for a round of frustration.

I really like the customization that you have done to Budgie. It looks really nice. I gave Budgie a shot before and it just did not sit well with me. I do not know why. Mate just works for me and my workflow. It could be all the time I spent with Gnome 2.X.

The joy of Linux, we can all find something that works for us.

3 Likes

Samba is a pain - nfs is much to prefer but if you are running windows systems smb is almost unavoidable.

With Samba 4.11 the SMB1 protocol was disabled to mitigate the wannacry ransomware and that change caused a lot of headaches around the world.

There is a great document on the various SMB versions in the following article (I use if for reference now and then)

As you are controlling both server and client you could get away with setting

client min protocol = SMB3
server min protocol = SMB3

Some routers with non upgradable samba requires the client to set

client min protocol = NT1
3 Likes

@Root Thanks for the information. That article is really good. I have added it to my “documentation toolbox”.

3 Likes