My ethernet is not being recognized by Network Manager

This is sort of a strange issue, but basically, I have had 3 endeavourOS systems running in the last month and after a few days the ethernet stops on them all. The first time I believe happned when I enabled the testing repo, then after rebooting it didn’t recognize my ethernet cable. I removed this repo and rolled back the updates (ethtool was updated in this). However ethtool naturally updated on my current system without issue. After yesterdays, which included a kernel update, my ethernet cable is no longer recognized. I don’t know for sure how to diagnose this issue.

Hello @wpeace
Please post inxi -Na

Edit: Would like to see the output from each.

Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: N/A modules: r8169
port: 4000 bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8723be
v: kernel port: 3000 bus-ID: 0d:00.0 chip-ID: 10ec:b723 class-ID: 0280

Okay so maybe it is being recognized? Does that mean it is an issue with network manager?

Same issue with these (output while it was still working):

➜  ~ inxi -Na
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280 
           Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3 
           class-ID: 0200 

WiFi still works, but Ethernet is dead. Luckily I have a Timeshift backup from two days ago.

Must be due to one of these packages (pending updates after the backup restore):

Packages (45) alsa-card-profiles-1:0.3.32-1  amd-ucode-20210716.b7c134f-1  aqbanking-6.3.0-2  ceph-libs-15.2.13-2  cfitsio-1:4.0.0-1  curl-7.78.0-1  eos-bash-shared-1.8.5-1  f2fs-tools-1.14.0-2  firefox-90.0.1-1  fmt-8.0.1-1  graphviz-2.48.0-1
              gst-plugin-pipewire-1:0.3.32-1  imath-3.1.1-1  inxi-  ldb-1:2.4.0-1  lib32-at-spi2-core-2.40.3-1  lib32-curl-7.78.0-1  lib32-gtk3-3.24.30-1  lib32-nettle-3.7.3-1  lib32-systemd-249.1-1  libbytesize-2.6-1  libjcat-0.1.8-1
              libmm-glib-1.16.8-1  libnm-1.32.4-1  libreoffice-fresh-7.1.5-1  libuv-1.42.0-1  libxmlb-0.3.2-1  libxnvctrl-470.57.02-1  linux-5.13.4.arch1-1  linux-firmware-20210716.b7c134f-1  linux-headers-5.13.4.arch1-1  modemmanager-1.16.8-1
              networkmanager-1.32.4-1  pipewire-1:0.3.32-1  pipewire-media-session-1:0.3.32-1  python-more-itertools-8.8.0-1  python-requests-2.26.0-1  r8168-8.049.02-4  signal-desktop-5.10.0-1  systemd-249.1-1  systemd-libs-249.1-1
              systemd-sysvcompat-249.1-1  tevent-1:0.11.0-1  vpnc-1:0.5.3.r496.r153-2  wine-staging-6.13-1

Did you try downgrading the network manager? Or going back via time shift? The issue is the same the fact ethernet is not working but both are different hardware chips so it may be network manager on both or maybe not?

Edit: It’s possible it’s NetworkManager but i haven’t had any issue.

Have you tried the r8168 package?

yay -S r8168


I have that package installed, but I will try reinstalling.

I will try to isolate the package updates on Sunday and will report back, thanks.

isn’t r8168 the package that has been known to cease ethernet broadband access?

Well it can but some chips don’t work on the r8169 also so this is just check and see if it works on the r8168. If it doesn’t then it my suggestion would be try downgrade NetworkManager. But the kernel module r8169 is part of the kernel so it may be the new kernel is the problem. That’s why i wanted to check if the r8168 works or not?

at least on my system ethernet WORKS with r8169,

if r8168 is present, ethernet broadband access CEASES

If the r8168 is already installed then remove it and reboot!

Edit: It may be that is the problem. I didn’t know you had it installed already. But i see your post after.

I have both installed and i have no issue. Mine works on either. Like i said it depends on the hardware.

If I remove that package, won’t wifi also cease, should I install a different package first?

If you remove the r8168 as you said it is installed may be the issue why the ethernet is not working. When you reboot it loads the r8169 kernel module. Your wifi is a different module. So try uninstall r8168 and reboot.

Thx, that worked!

Okay so you said you had 3 computers with similar issues. You can look at inxi -Na on those also and see what ethernet chips and wifi chip they have. It may be the same issue or not.

For me downgrading the kernel did the trick.

So it seems I have to ignore the following update, until there is a fix:

Name           Current          ->  New             DownloadSize
----           -------          --  ---             ------------
linux          5.12.15.arch1-1  ->  5.13.4.arch2-1  124,31 MiB
linux-headers  5.12.15.arch1-1  ->  5.13.4.arch2-1  23,63 MiB

Your wifi is iwlwfi which is intel. The r8168 package is an installed package but not for your hardware. So the updated kernel must have an issue with respect to iwlwifi.

I am not sure I understand. My WiFi was working fine on both kernels. Ethernet was only working for the older version. So instead of iwlwifi, igc must be the culprit, right?