Mumble using wrong browser, when clicking URL

When I click an URL posted in mumble, Chromium is started instead of using Firefox (which is set as default browser in system settings). I’m using Plasma/KDE as DE.
The GUI of mumble doesn’t provide any option to change the browser.
I also already had a look at ~/.config/Mumble/mumble.conf. No setting available there. Also, mumble itself doesn’t provide a config for system-wide use.
Maybe somebody can push me in the right direction on how to solve this strange behaviour.

yay -Qs mumble
local/mumble 1.3.4-9
    An Open Source, low-latency, high quality voice chat software (client)

Thanks in advance

What’s this returning?

xdg-settings get default-web-browser

I guess this was a hit

xdg-settings get default-web-browser

Any idea how to change it?


xdg-settings set default-web-browser firefox.desktop


Works perfectly.
Thanks for your quick response.

Do you have any idea, what might have caused the issue?
Could it be that another DE, which is installed parallel to Plasma, changed the setting?

Seems to be some issue with xdg-utils and plasma.
Apparently it has been fixed in the meanwhile, but no new release was made yet, so the fix did not yet make it downstream to arch :man_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.