Multiboot usb live image doesn't work

Hey, so i tried to add EndeavourOS to my multiboot usb stick using the Multiboot USB package and when trying to boot Endeavour OS it says that i need to boot the kernel first, and that it did not find /boot/vmlinuz-linux.

I like having multiple live images ready to boot from on my usb stick, so i tried it with a handful of other distros already on my stick such as ubuntu, debian, fedora, arch, and manjaro. But this is the only distro having this issue.

The error seems like it doesn’t give much info, but if its any consolation i tried both with the distro installed to the usb as well as booting to the iso using the grub2 bootloader.

Additional note, love the distro so far, switched my laptop to it, dual booting my work laptop on it, and likely will switch my gaming rig to it from manjaro.

I’ve had the same issue the couple of times that I’ve tried. Supposedly, MultibootUSB can detect an arch image and set it up correctly, but that doesn’t seem to always be true. I would suggest taking a look at the issues on the MultibootUSB github repo and see if there is anything useful there.

Ventoy is pretty straightforward app for setting up a multiboot usb flashdrive.

1 Like

I really like that, I tried it out and it fails mounting /dev/loop0 to /run/archiso/airootfs and errors out with:

unable to read xattr id index table
mount: /run/archiso/airootfs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error and then drops me to a root shell.

I do like this better than MultibootUSB though. Not sure how i’ve never found this in my quest for a great multiboot usb flash drive tool.

EDIT1: I must be doing something totally wrong, i can’t get it to boot anything. EndeavourOS is on its supported list, so this may be more of a pebcak error :stuck_out_tongue_winking_eye:

EDIT2: Ventoy works, but it hates my Dell XPS 15 9530 i guess.

EDIT3: It now for no reason has begun working on my Dell XPS 15 9530. I’ve changed nothing other than copy all the iso files again after a reformating again (5th try). I can confirm multiple OS’s work (including Hirens boot CD), gparted live does not, but that could be a different issue.

EDIT4: For those who may find this, gparted works too now… still no idea why, but I’m guessing a higher quality flash drive and re-copying the iso files must have helped as that is all that has changed.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.