Mpd and mcg help please

good day all

i have been playing around with my mpd conf file but i’m not coming right. what i’m trying to do is get mpd running and point it to my mp3’s that i ripped from my cd collection that is on my smb/nfs share that is on another system. so the whole setup is only for lan

music_directory “nfs://attic/music/”
playlist_directory “/home/angelus/.config/mpd/playlists”
db_file “/home/angelus/.config/mpd/database”
log_file “/home/angelus/.config/mpd/syslog”
pid_file “/home/angelus/.config/mpd/pid”
state_file “/home/angelus/.config/mpd/state”
sticker_file “/home/angelus/.config/mpd/sticker.sql”
user “angelus”
bind_to_address “any”
bind_to_address “”
port “6600”
log_level “verbose”
database {
plugin “simple”
path “/home/angelus/.config/mpd/db”
cache_directory “/home/angelus/.config/mpd/cache”
music_directory “nfs://attic/music/”
database {
plugin “proxy”
host "router IP ?? "
port “6600”
input {
plugin “curl”
audio_output {
type “alsa”
name “My ALSA Device”
server “”

if i run mcg update i get a error of

(mcg:5534): GLib-GIO-CRITICAL **: 01:42:04.378: This application can not open files.

a systemctl status mpd gives me

mpd.service - Music Player Daemon
Loaded: loaded (/usr/lib/systemd/system/mpd.service; disabled; vendor preset: disabled)
Active: active (running) since Mon 2021-05-03 02:12:56 SAST; 1min 48s ago
Docs: man:mpd(1)
Main PID: 6486 (mpd)
Tasks: 3 (limit: 19122)
Memory: 9.0M
CPU: 86ms
CGroup: /system.slice/mpd.service
└─6486 /usr/bin/mpd --no-daemon

May 03 02:12:56 Angelus systemd[1]: Starting Music Player Daemon…
May 03 02:12:56 Angelus mpd[6486]: exception: bind to ‘’ failed (continuing anyway, because binding to ‘[::]:6600’ succeeded): Failed to bind socket: Address already in use
May 03 02:12:56 Angelus mpd[6486]: exception: Decoder plugin ‘wildmidi’ is unavailable: configuration file does not exist: /etc/timidity/timidity.cfg
May 03 02:12:56 Angelus mpd[6486]: config: Found database setting without music_directory - disabling database
May 03 02:12:56 Angelus mpd[6486]: output: No ‘audio_output’ defined in config file
May 03 02:12:56 Angelus mpd[6486]: output: Successfully detected a alsa audio device
May 03 02:12:56 Angelus systemd[1]: Started Music Player Daemon.
May 03 02:12:57 Angelus mpd[6486]: avahi: Service ‘Music Player @ Angelus’ successfully established


Is an instance already running?

hi there

when i start up my pc it doesnt auto start to start i just type mpd in the terminal and it starts or i can use systemctl start mpd




Binding to IPV6 before IPV4

If on startup, mpd displays the following message:

listen: bind to ‘’ failed: Address already in use (continuing anyway, because binding to ‘[::]:6600’ succeeded)

it means mpd binds to the ipv6 interface before binding to ipv4. If you want to use your ipv4 interface, hardcode it in mpd.conf, like:

bind_to_address “”

Several binds can also be specified, for example, to have mpd listen both to localhost and to the external IP of your network card:

bind_to_address “” bind_to_address “”

which means then that

binding to ‘[::]:6600’ succeeded

so bind failed because it had succceded bind on [::]:6600

but still on mcg update it says

(mcg:19627): GLib-GIO-CRITICAL **: 10:37:26.977: This application can not open files.

edit : solved … found another player that suits better