Mouse intermittently freezes while computer runs normally

Hello all,
I have a mouse that works perfectly fine on other computers, but will seemingly randomly stop working for half a second to 2 seconds at a time on my pc. I can go long periods without it being a problem, then sometimes it keeps happening 10 times a minute. The mouse is still connected and lit, the cursor just freezes, while videos and games continue at normal speed in the background.
My pastebin is here
I’m just really frustrated by this, the mouse is known to work on other computers ha. I’ve tried swapping it between mobo and case usb slots, updated the linux kernel, the mobo BIOS. I also suffered this problem in my previous Manjaro XFCE install (KDE Plasma with EOS now). Maybe I’m just suffering USB ghost’s and need a PS2 mouse? ha

Maybe you need to try a new usb-mouse? They come starting from $5.90… (Logitech). Just saying. Might be worth a try before bricking your PC’s Bios.

Welcome to the forum @LeEmu ! :enos:

1 Like

Welcome to the EndeavourOS forums. I hope you enjoy your time here. It also helps if you like purple.

You said you tried this mouse on other computers. Have you tried using a mouse from one of those other computers on the problem computer?


1 Like

Hmm, feeling like a dummy atm. My other computers were laptops, so no mice with them, and I was so sure the mouse was fine because it worked on the laptops ha. Have a new mouse going with no issues atm, but it’s always been an intermittent issue, so fingers crossed it doens’t come back.
Cheers guys >.<

1 Like