Mouse input 'boxed' in to view ranges across several games

Hello all, recent Manjaro convert here, liking what ive got so far but… (hardware specs at bottom of post)

Hopefully this is the proper area to post this.

To explain the behavior a little further:

Mouse input seems to be locked into a box of sorts and only allows for a limited field of input.
I have tried a couple of mice that I have lying around (Logitech 502x and an old Logitech G700) the issue persists across both of them, I currently do not have any non-wireless mice to test on. Mouse input on both mice works normally outside of any games. Additionally any Keyboard inputs work without issue

I saw another post about the mouse input spinning around and have disabled the Screen Edge Interactions per the recommendation in that post but the issue has persisted. (It is possible that I have not disabled it properly.)

So far I have tested this issue across a few titles:

Deep Rock Galactic: Mouse input is limited to a box, approximately an inch in from the edge of the monitor, allows for approximately 180 degrees of movement before hitting a ‘wall’.

Ready or Not: Issue is similar to Deep Rock, with the exception of the camera having the ability to jump around. After jumping to a new point it is once again limited to that 180 degree field of view.

Helldivers 2: Mouse input does little to nothing to the camera unless the in-game sensitivity is maxed out, in which the camera controls almost function like a Joystick where the camera snaps to center after moving one direction.
Worth noting that Controller input works fine on HD2, however my controller is unplugged unless I’m actively using it.

Star Citizen: Seems to be the exception, camera movement is fully functional until I attempt to use the interact Key (Holding F) in which case the Camera will snap straight down to the ground. This is possibly a different issue but seemed worth noting just in case.

Ive done a bunch of hunting around, either I’m searching for the wrong terms or I’m simply not finding the correct results.

Appreciate all y’alls help in solving this one.

Thanks.

PC Specs:

OS: EndeavourOS Plasma 6 (Wayland)
MOBO: MSI MEG X570S Unify-X MAX (BIOS ver. 1.80)
CPU: Ryzen 9 5950x
GPU: Radeon 6900xt
RAM: 64GB
Storage: 2x Samsung 970 EVO 1TB

1 Like

Hi. Welcome to the forum. You’ve posted in the right place.

One thing missing from your specs is whether you are using X11 or Wayland. At the moment, this is actually very significant. And on that note, have you tried using either to see if there is a difference?

1 Like

Just confirmed that im running Wayland. At current I have not tried switching that around so see if the behavior goes away. Ive also edited the inital post with that info.

Okay.

Well, go ahead and give it a test when you can. If you aren’t tied to Wayland yet and the issue isn’t present in an X11 session, then you can use X11 for now.

PS: There really isn’t any reason to be “tied to Wayland” on a DE - only WMs really have any benefit at the moment imho.

1 Like

Just tried switching it over to X11, so far Deep Rock and Ready or Not are fully functional again, outside of some other performance issues unrelated to the post. I’m testing the last two titles and will update this post accordingly with the results but I think you hit the nail on the head.

Additionally I’m new to both Plasma and EndeavourOS so I was unaware of the whole Wayland/X11 thing. I highly appreciate the info.

Edit: All previously tested titles are fully functioning as expected now. Definitely seems to be tied to something with Wayland.

Thanks again for all the help!

2 Likes

You’re welcome. Glad to help.

1 Like

I solved this by just rebooting. Still running wayland- now yet again without issues.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.