Mouse based workspace switching completely broken

Since today’s upgrade, mouse based workspace switching is completely broken for me in desktop mode.
Workspace switching via mousewheel has been broken for a while, now I can’t even switch workspaces with a middle click anymore. Middle clicking simply doesn’t do anything.
I tried to downgrade kwin, but this did not solve it, so I presume some other package is responsible for this.
Any ideas to get mouse based workspace switching back?
J.

EDIT - ah, I completely missed this line from your first sentence:

completely broken for me in desktop mode.

Sorry. I haven’t had my coffee yet.

Some users have been reporting this bug since April; the latest related bug report came in just 3 days ago (Nov 19).

Changing desktop from “folder view” to “desktop view” seems to be a (workaround) fix for some people:

Status of the bug report is “Confirmed” so it’s an ongoing thing.

If you create a new user, does the mouse scroll switching work?

Am I really the only one with this problem?
J.

Check if middle click still has “workspace switching” as it’s configured action…

Guess how often I have checked that in the last two days.
J.

Many! :grin:

I had same issue about a month back . I solved the problem by changing the setting from folder view back to Desktop .

  • Right click on desktop and select ( configure desktop and wallpapper ).
  • Change the Layout from folder view to Desktop , and apply .
    This solved my problem at the time . Hope it works .

All my data points to: Not once :stuck_out_tongue_closed_eyes:

Your data seems to be wrong.
All settings for workspace switching are correct, they just don’t have any effect.
.

May I ask what settings your looking at ?

I have never been able to make it work either. :disappointed:

It was awhile ago now but I had the same issue . I was scratching my head for weeks . It happened after an update . I tried in System Settings just about everything i could see . Played with mouse settings but still did not work .
I could not fix within System settings . At least that i could find .
The only way i fixed this was to access the settings by right-clicking on Desktop and selecting ( Configure Desktop and Wallper ) . There at the top is Layout: . Change from Folder view to Desktop .
If set on folder view changing desktop with mousewheel does not work . I just verified this now again and still apply .
This is the only way i am able to switch desktops using just my mousewheel .
If your looking for something else , that i misunderstood what you were asking for , I’m sorry . I watch this post to see how you eventually resolve your issue .

Some extra KDE System-Settings info to be careful of .
At the time since switching desktops with mousewheel wasen’t working , playing in settings thinking of switching desktops by using screen-edge . Unfortunitly if you auto-hide your bottom panel , and set the ( Switch desktop on edge ) set to , Always enabled , your bottom panel will become unexcessable . Will cause headache for some . Careful while playing .

I am aware that I can switch desktops in Desktop mode. But this disables everything on the desktop, so that’s no option for me. Changing workspaces with the middle mouse button has stopped working too in folder view.
Now I have even fucked up the possibility to switch between folder and desktop mode, as I have tried to assign workspace switching to my right mouse button, I can’t right click my desktop to access the settigs anymore :frowning:
J.
Edit: I had to change the file ~/.config/plasma-org.kde.plasma.desktop-appletsrc manually to get the old right click functionality back.

Damn sorry that happened , happy you got it back fast .

1 Like

Not what your looking for , but mousewheel on Pager wiget in panel works . Hope someone shows up with a real solution . Sorry I coulden’t help …

Can you explain how to do it exactly?

Edit: Sorry, I thought you had it figured out. Guess you had another problem?

Yes, new problem. First, workspace switching on the desktop by mousewheel stopped working in folder mode months ago (at least a confirmed plasma bug since april), last week workspace switching on the desktop by middleclicking and selecting a workspacel stopped working too in folder mode.
J.

1 Like

Are you using all your screen corners? I set one to show desktop grid, then select workspace with a left mouse click. It’s not the solution I know but it works for me and I’m fully up to date with my Plasma, nothing weird going on as far as I know.

That’s some kind of workaround, yes. Still not the functionality that I want back.
J.