Mounting NAS

How do I mount my nas at boot? I put // /mnt/share/nas/ cifs username=XXXX,password=XXXX 0 0 in /etc/fstab and it will mount the drives when I use mount -a. It will not mount when I reboot. I even put vers=2.0 with same results. Please advise, much appreciated. Thanks.

See this wiki page:

Here’s a method that has worked for me (substitute your credentials).

sudo mkdir -p /media/nas/yourfilename
sudo chmod 777 /media/nas/yourfilename
sudo chmod 754 /sbin/mount.cifs

In your /etc/fstab, add this to the bottom of the file (while substituting your credentials).

//yournasaddress/nameofnasfilename /media/nas/nameofnasfilename cifs domain=yourdomainname,x-systemd.automount,_netdev,users,uid=1000,gid=1000,rw,guest,vers=2.0 0 0

Thanks for the support. This is what has worked for me:
//yournasaddress/nameofnasfilename /mnt/local_nas cifs vers=1.0,username=xxx,password=xxx,x-systemd.automount,iocharset=utf8,sec=ntlm 0 0
Are there any liabilities related to using ver=1.0 or the login for the nas?
Also I am getting "A stop job is running for mnt/local_nas when I reboot or shutdown that lasts almost 2 minutes. How to mitigate? Thanks.

When I have experienced this in the past, using systemd mount units instead of fstab fixed it up.