More and more often desktop settings reset after reboot

I am aware that this is more of a plasma problem than an EOS problem, but it could still be that someone here has the same experience and already has a solution.
Since some time it happens more and more often that after a restart of EOS (KDE) both the background image and the settings for the shortcuts were reset. Also all widgets are gone. It probably does not happen depending on a previous update, rather sporadically. But it sucks!!!


The symbols will all be placed on the top left again. Theme Breeze Standard

I don’t understand how this happens? What sort of settings and shortcuts and widgets do you make?

This should be fixed in 5.26 :


By settings are meant: arrangement of symbol shortcuts, disabling the preview for Sybol shortcuts and files, background image. All this + added widgets will be reset after a restart.

I don’t even know what this setting is or where? I never make this kind of change yet.

Sorry, but I can’t find anything in any of the bug lists that describes this problem, but my English is not good either.

for example this one:

I’m not sure which screen in settings?

Not via the settings, but right-click on the desktop → desktop and set up wallpaper

Okay… i see here my settings not changed.


Do you have enough disk space to update?

more than enough

It happens to me too. Not often, but it happens.
I’ve already stopped wasting my nerves on this.

You right, its not the good link and i don’t find the correct one :expressionless: But yeah happen to me too. Now i have a doubt, pretty sure its fixed in 5.26 (maybe already on the beta ?).

For the background, you can run a script at start-up like me:

plasma-apply-wallpaperimage /home/goldnenex/pictures/bg.jpg

If you have multiple screen that will change all the screen background and sadly its the limit of this command

1 Like

Thanks @GolDNenex , that helps me. So I wait to 5.26 … :unamused:

1 Like

This is very strange, nothing like this happens to me. The only thing atypical is I usually only mess with my settings once…and then they stay forever. I run Wayland (if that affects anything at all).

Does not happen to me, either (KDE Plasma on Fedora 36 & Rawhide).

I could well imagine that making a difference.

It has also occurred on my girlfriend’s computer.

I run Plasma on Xorg, as my old HW doesn’t cope well with Wayland at all, it simply crashes on any first boot.