Monitors not sleeping

For the past few days, my monitors have been refusing to sleep on my main system build. Even stranger, they HAVE slept a couple of times - with no indication of what the difference in outcome might be.

It does not seem to be hardware related, as I have 4 other builds of similar setups on this same machine, and the problem does not arise on them. The other setups are: Garuda (btrfs), EnOS (f2fs), EnOS (btrfs), and an Arch build (ext4). All run xfce, all are fully updated - and I can’t find a likely candidate (from my limited understanding) for an update oddity in the first place! When this first occurred, with the excuse of ‘being busy’, I waited a while to see if it went away - as it well might if related to an update. I guess I can dive deep into how this is usually managed, but surely it is worth seeing if someone here has a clue that I don’t! (Or at least a direction to point my searches at.)

Here’s an inxi -Faz, in case that might help - and a rem

inder that the current settings I have implemented through xfce worked for the last 2 years without issue - and continue to work on all the other builds on this physical machine…

inxi -Faz
┌18:27:49 WD= [~]
└───freebird@nest ─▶$ inxi -Faz
System:
  Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: root=UUID=538b9f7d-c154-49af-be53-6f2e88747d6a rw
    resume=UUID=185941c4-f3d0-4e48-a621-5a7457f83e00 nowatchdog
    add_efi_memmap sysrq_always_enabled=1 initrd=\boot\amd-ucode.img
    initrd=\boot\initramfs-linux-zen.img
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel, plank
    wm: xfwm v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: EndeavourOS
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 1407
    date: 04/01/2020
CPU:
  Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2766 high: 4319 min/max: 2200/4426 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3592 2: 2060
    3: 2191 4: 2392 5: 2387 6: 2163 7: 3868 8: 2094 9: 4319 10: 2194 11: 2053
    12: 2391 13: 4232 14: 2081 15: 4179 16: 2065 bogomips: 114986
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN 4
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: DVI-D-1,HDMI-A-2 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 08:00.0
    chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: amdgpu unloaded: fbdev,modesetting,vesa gpu: amdgpu
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5640x2400 s-dpi: 96 s-size: 1492x635mm (58.74x25.00")
    s-diag: 1622mm (63.84")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: right model: NEC LCD2090UXi
    serial: <filter> built: 2006 res: 1800x2400 hz: 60 dpi: 149 gamma: 1.2
    size: 306x408mm (12.05x16.06") diag: 510mm (20.1") ratio: 4:3 modes:
    max: 1600x1200 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-A-1 pos: primary,left
    model: BenQ EL2870U serial: <filter> built: 2018 res: 3840x2160 hz: 60
    dpi: 157 gamma: 1.2 size: 621x341mm (24.45x13.43") diag: 708mm (27.9")
    ratio: 16:9 modes: max: 3840x2160 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
RAID:
  Device-1: zdata type: zfs status: ONLINE level: linear raw: size: 2.72 TiB
    free: 1.17 TiB allocated: 1.55 TiB zfs-fs: size: 2.63 TiB free: 1.09 TiB
  Components: Online:
  1:
Drives:
  Local Storage: total: raw: 3.69 TiB usable: 9.05 TiB used: 1.62 TiB (17.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: EGFM11.3
    temp: 47.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3000DM001-1CH166
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC27 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk
    model: Ultra USB 3.0 size: 57.3 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 244.14 GiB size: 239.25 GiB (98.00%)
    used: 71.36 GiB (29.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 235.2 MiB (23.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:
  System Temperatures: cpu: 41.5 C mobo: 42.0 C gpu: amdgpu temp: 54.0 C
  Fan Speeds (RPM): fan-1: 950 fan-2: 1677 fan-3: 991 fan-4: 0 fan-5: 3006
    fan-6: 0 fan-7: 0 gpu: amdgpu fan: 1130
Info:
  Processes: 465 Uptime: 3m wakeups: 0 Memory: 31.32 GiB
  used: 9.17 GiB (29.3%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1453 lib: 299
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.17

Thanks for any ideas!

A classic advice :wink: :

Check journal

Look for the point that sleep might start, or a sign about monitors.
My guess Crystal Ball :crystal_ball: says that there is a running process or program that wakes up the monitors. I would suggest you check dpms settings, but you said you haven’t changed settings for 2 years and for the other systems as well. :person_shrugging:

I had this behavior lots with my old nvidia build. With AMD only I have sleeping issues :crazy_face:

A bit of a non-event here… it stopped doing this with as little warning as it began. My first thought when it would not ‘sleep’ is that some item had gotten an update, and that a further update would fix it… this COULD have been the case. The only odd bit is that it didn’t happen on the other builds on this same machine.

So - I will mark it as solved, although my knowledge has NOT increased (I still couldn’t decide what to look for in the journals) - at least marking it as solved should close the thread! :grin:

Update - I guess it isn’t solved - it stuck ‘on’ again. I’m leaving it marked solved though - perhaps I’ll go low-tech and hit the power switches (when I remember)…

(sigh)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.