Monitors not going to sleep - display black background instead

Hello,
I’m running Gnome and I can’t get my monitors to sleep after a specific period of time (in Gnome settings power section I have it set to 15 mins).
The monitors just start showing a black background instead and moving my mouse shows me login screen.
Doing sleep 1; xset dpms force off works just fine so I’m confused?
Usually this happened after kernel update and I needed to reboot but this time it broke a few kernel updates ago and nothing seems to fix it.
I’m running RTX 3070 with Nvidia drivers.

This is the normal behavior. It’s not the login screen, it’s the session lock screen, which looks the same.
What was the previous behavior, or what you expect exactly?

But the monitors do not enter sleep mode, I can see the backlight is still on and the monitor LED is ON.
What should happen is monitors should enter sleep or power saving mode - backlight should turn off completely and LEDs should be blinking indicating monitor is in power saving mode.

Ok I kinda solved it…
so I did xset dpms 0 0 60… now it works and turns off my monitor every minute… except I can no longer set it to xset dpms 0 0 900 it just keeps turning off every minute.

❯ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 900
  DPMS is Enabled
  Monitor is On

Something is seriously wrong here…

Was this the previous behavior?
Which packages were added or updated before this started ?
Is power-profiles-daemon installed and if so, when was it initially added?
Read more, since it’s a complicated issue, with many factors (HW and SW).
At least:
https://wiki.archlinux.org/title/CPU_frequency_scaling#power-profiles-daemon

Also check:
https://wiki.archlinux.org/title/Display_Power_Management_Signaling
PPD issues

Post the results of your troubleshooting investigation, as proposed from the above.

Ok now I see what happened, the software didn’t change, however my hardware did - I had to buy a new monitor and it behaves differently.
So what is happening is my monitors go to power saving as usual, but the new monitor stops being detected by the system, so after a few seconds in power saving mode window manager readjusts for only 2 displays which causes all monitors to wake up, this again triggers OS to readjust for 3 screens but now the displays are no longer sent to power saving mode, gnome simply starts showing black screen after a while.

I have no idea how to solve this? All monitors are connected over Display Port.
There is nothing related to power saving settings in monitor OSD except what power button does but it is not helpful. The monitor is MSI mag274qrf-qd but I doubt it depends on the monitor, must be something related to Display Port itself?

I suppose you have not read the monitor’s User Manual, or have you? What does it say on this matter?

There is nothing useful in the user manual about the power saving mode, only a special HDMI mode for consoles and such but I can’t use HDMI because of 165Hz

Post a link to the manual.

Also provide more info (garuda-inxi output). Edit: :face_with_head_bandage: Mixed forum :joy:

You mean this?

❯ inxi -faMzSG
System:
  Kernel: 5.16.15-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/vmlinuz-linux
    root=UUID=c13714ba-4389-4b48-b547-8b95e691c819 rw rootflags=subvol=@
    acpi_enforce_resources=lax quiet splash
    cryptdevice=UUID=bd1174a3-4cab-4a9a-92f1-2aa046e0d621:luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621
    root=/dev/mapper/luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621 loglevel=3
    nowatchdog nvme_load=YES
  Desktop: GNOME 41.4 tk: GTK 3.24.33 wm: gnome-shell dm: GDM 41.3
    Distro: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2423
    date: 08/10/2021
CPU:
  Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 2477 high: 4537 min/max: 2200/5160 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2983 2: 2591
    3: 2654 4: 2649 5: 2529 6: 2947 7: 2027 8: 2014 9: 2037 10: 2024 11: 2046
    12: 2183 13: 4537 14: 2647 15: 2657 16: 2663 17: 2661 18: 3351 19: 2039
    20: 2050 21: 2050 22: 2072 23: 2027 24: 2027 bogomips: 177683
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni
    popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep
    sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3
    stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip
    v_spec_ctrl v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ASUSTeK driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 08:00.0 chip-ID: 10de:2484 class-ID: 0300
  Device-2: Creative Live! Cam Sync 1080p V2 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.3:9 chip-ID: 041e:40a0
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.3 compositor: gnome-shell driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 7680x1440 s-dpi: 96 s-size: 2032x381mm (80.0x15.0")
    s-diag: 2067mm (81.4")
  Monitor-1: DP-0 pos: right res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Monitor-2: DP-2 pos: primary,left res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Monitor-3: DP-4 pos: primary,center res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.54 direct render: Yes
1 Like

More:

inxi -Faz
xrandr
❯ inxi -Faz
System:
  Kernel: 5.16.15-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/vmlinuz-linux
    root=UUID=c13714ba-4389-4b48-b547-8b95e691c819 rw rootflags=subvol=@
    acpi_enforce_resources=lax quiet splash
    cryptdevice=UUID=bd1174a3-4cab-4a9a-92f1-2aa046e0d621:luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621
    root=/dev/mapper/luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621 loglevel=3
    nowatchdog nvme_load=YES
  Desktop: GNOME 41.4 tk: GTK 3.24.33 wm: gnome-shell dm: GDM 41.3
    Distro: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2423
    date: 08/10/2021
Battery:
  Device-1: hidpp_battery_0 model: Logitech G604 Wireless Gaming Mouse
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: Discharging
CPU:
  Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 2377 high: 3259 min/max: 2200/5160 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2207 2: 2984
    3: 2660 4: 2669 5: 2655 6: 3213 7: 2037 8: 2032 9: 2029 10: 2036 11: 2029
    12: 2075 13: 3259 14: 2682 15: 2657 16: 2649 17: 2143 18: 2808 19: 2041
    20: 2029 21: 2039 22: 2020 23: 2062 24: 2046 bogomips: 177683
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ASUSTeK driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 08:00.0 chip-ID: 10de:2484 class-ID: 0300
  Device-2: Creative Live! Cam Sync 1080p V2 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.3:9 chip-ID: 041e:40a0
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.3 compositor: gnome-shell driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 7680x1440 s-dpi: 96 s-size: 2032x381mm (80.0x15.0")
    s-diag: 2067mm (81.4")
  Monitor-1: DP-0 pos: right res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Monitor-2: DP-2 pos: primary,left res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Monitor-3: DP-4 pos: primary,center res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.54 direct render: Yes
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 08:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Texas Instruments SMSL AD18 AMP type: USB driver: snd-usb-audio
    bus-ID: 1-1.2:6 chip-ID: 0451:0003 class-ID: 0102
  Device-4: Creative Live! Cam Sync 1080p V2 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.3:9 chip-ID: 041e:40a0
    class-ID: 0102 serial: <filter>
  Device-5: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.4:10
    chip-ID: 0c76:161e class-ID: 0300
  Sound Server-1: ALSA v: k5.16.15-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-e2c8e129f5a3 state: down mac: <filter>
  IF-ID-2: br-e5efaba6d3d8 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-3: docker0 state: down mac: <filter>
  IF-ID-4: vethd2d67e7 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-5: vethe91f2b0 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1.3:7 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 3.68 TiB used: 183.98 GiB (4.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: A-Data model: SX8200PNP
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 42B4S9NA temp: 35.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z44106
    temp: 37.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: GPT
Partition:
  ID-1: / raw-size: 1.86 TiB size: 1.86 TiB (100.00%) used: 183.71 GiB (9.6%)
    fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621
  ID-2: /boot raw-size: 1024 MiB size: 975.9 MiB (95.30%)
    used: 278.3 MiB (28.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:7
  ID-3: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 1.3 MiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:6
  ID-4: /home raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
    used: 183.71 GiB (9.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621
  ID-5: /var/log raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
    used: 183.71 GiB (9.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bd1174a3-4cab-4a9a-92f1-2aa046e0d621
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 44.5 C mobo: 34.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 320 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0
    fan-7: 368
Info:
  Processes: 590 Uptime: 12h 1m wakeups: 20 Memory: 31.32 GiB
  used: 7.43 GiB (23.7%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1290 lib: 406 Shell: Zsh v: 5.8.1
  running-in: gjs inxi: 3.3.13
❯ xrandr
Screen 0: minimum 8 x 8, current 7680 x 1440, maximum 32767 x 32767
DP-0 connected 2560x1440+5120+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440    120.00*+  59.95  
   1920x1080    119.88    60.00    59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-2 connected 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440    120.00*+  59.95  
   1920x1080    119.88    60.00    59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 2560x1440+2560+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.94 + 164.83*  120.00  
   3840x2160     59.94    29.97  
   1920x1080    164.89   119.88   100.00    60.00    59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x720     119.88   100.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-5 disconnected (normal left inverted right x axis y axis)

Check for PM settings for monitors in Nvidia Settings.

Other than that, search at the previous post links or more on the web for this.
It’s a special case with 3 identical monitors, all DP and only one is disabled. :thinking:
Are they all the same model or company?
Have you tried switching ports on GPU?

I think I fixed it, I disabled input auto scanning in monitor OSD and locked it to display port, seems it is no longer “lost” to the system when going into power saving mode!
I will report back if it happens again but looks promising, thanks for the help :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.