Monitor problems

Since I did last update (today) every 20 seconds my monitor turns black for 5 seconds and then turns back. Impossible to work, very annoying! Any suggestions?

Post the output of inxi -Faz so people can see what your system is, and identify which packages you updated by looking in /var/log/pacman.log .


Hello, thanks for your answer. This is the demanded output:

 Kernel: 5.15.7-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=d9817b3c-a8fd-4f82-9b08-41de8ea4f911 rw quiet loglevel=3
  Desktop: GNOME 41.2 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P8Z77-M PRO v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 1504
    date: 08/03/2012
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
Use of uninitialized value $val2 in string eq at /usr/bin/inxi line 6943.
Use of uninitialized value $val2 in split at /usr/bin/inxi line 6948.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 6950.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 6953.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 6954.
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes status:
  Info: model: Intel Core i3-2100 bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1627 high: 1694 min/max: 1600/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1605 2: 1605 3: 1605
    4: 1694 bogomips: 24882
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD RV620 LE [Radeon HD 3450] vendor: ASUSTeK driver: radeon
    v: kernel bus-ID: 01:00.0 chip-ID: 1002:95c5 class-ID: 0300
  Display: wayland server: compositor: gnome-shell driver:
    loaded: radeon note: n/a (using device driver) - try sudo/root
    display-ID: 0 resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: AMD RV620 HDMI Audio [Radeon HD 3450/3470/3550/3570]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aa28 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.41 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8168 v: 8.049.02-NAPI modules: r8169
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 704.24 GiB used: 139.85 GiB (19.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: ST9500424AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: HDD
    rpm: 7200 serial: <filter> rev: 0214 scheme: GPT
  ID-1: / raw-size: 238.47 GiB size: 233.67 GiB (97.99%)
    used: 16.18 GiB (6.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 63.0 C
  Fan Speeds (RPM): N/A
  Processes: 213 Uptime: 5m wakeups: 2 Memory: 7.72 GiB
  used: 1.26 GiB (16.3%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 879 lib: 248 Shell: Bash v: 5.1.12
  running-in: gnome-terminal inxi: 3.3.10

MOD Edit: Fixed Formatting

Have you tried switching to the lts kernel and/or X11?

Is it exactly everytime 20 secounds or is it sarcasm?

Tried to disable screensaver and disable the energy options under settings?

1 Like

Also what extensions are you using with Gnome?

No, it’s not sarcasm. The strange thing is the following: the longer the computer runs, the problem get’s worser. After working 30 minutes it happens maybe every two minutes, later it literally happens all 10 seconds and I must jump to my windows installation. Of course it’s impossible to do anymore work.

I would definitely try the LTS kernel. It is an easy thing to test out.

sudo pacman -S linux-lts linux-lts-headers

Then reboot and choose the LTS option from the boot menu

1 Like

As well, you should check your temperatures, since high temperatures can cause driver to crash which converts in experience you have.

Are you overclocking, gaming?

Also did you try login in the xorg instead Wayland session, maybe worth a shot too, in addition to running lts kernel.

Hello dalto,
did this, but no changes. In the boot menu I did not have had the option to choose, but I think the LTS Kernel was loaded anyway, because the internet connection has gone.

No, no overclocking, no gaming. Yes, I tried to login with xorg, nothing changed. Also did change to XFCE instead Gnome, did change nothing. Also already tried all display managers, nothing better.

Hello razor,
this is an interesting idea. Will check temperature. But if this is indeed the problem, it seems related to Linux.
If so, how can this be resolved? On Windows never had something similar.

If that is the problem, you can look into TLP.

1 Like

This doesn’t tell us much, except that it may be related to your Linux install or proprietary/unsupported hardware driver.

Try lts kernel as mentioned twice above before trying anything else, sometimes it’s a driver update in the kernel.

As there is a parallel thread on the very same topic let’s close this one here. @moderators

That topic is a bit different than this one and it doesn’t seem like the problem has been solved so I think it is OK to leave both open.

Thanks to all here and also I wish you all a Happy New Year!

The solution finally was so simple: I changed from HDMI to Display Port and everything is fine! No more problems. Maybe something was wrong with the cable. And I switched back from Manjoro to Endeavouros.

1 Like