Monitor goes blank

In my Endeavour Plasma installation in random times my monitor turns blank like is suspended or something. If i press a key or move the mouse it goes back to normal. I have try to configure in the energy settings but still the same

To understand better your situation, will help if you could share your hardware specs.
inxi - F could help a lot.

System:    Host: andreasdimo Kernel: 4.19.99-1-lts x86_64 bits: 64 Desktop: KDE Plasma 5.17.5 Distro: EndeavourOS 
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <root required> 
           Mobo: ASUSTeK model: H81M-C v: Rev X.0x serial: <root required> BIOS: American Megatrends v: 3602 date: 03/26/2018 
CPU:       Topology: Dual Core model: Intel Pentium G3420 bits: 64 type: MCP L2 cache: 3072 KiB 
           Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.7 driver: intel resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.99-1-lts 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 38:2c:4a:b4:83:8b 
Drives:    Local Storage: total: 223.58 GiB used: 62.35 GiB (27.9%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0A-00JH30 size: 223.58 GiB 
Partition: ID-1: / size: 211.01 GiB used: 62.35 GiB (29.5%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.18 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 152 Uptime: N/A Memory: 3.73 GiB used: 1009.1 MiB (26.5%) Shell: bash inxi: 3.0.37

I see your are using Intel integrated graphics, is that correct?

Yes, thats what i am using

Unlike yours, in a system of mine, I have the oposite case. The screen doesn`t go blank after the set time. Being an old-time plasma user, I have noticed that this is happening after plasma updates (not always). All I do is set the time parameters again & the issue is solved, thereafter.

Mine is set like this and works properly.

Even with setting to 360 minutes still goes blank

The parameter’s in my system is OK, but the results are the same

What is your screen locking set to?
Settings > Workspace behavior > Screen locking

@AndreasDimo
Maybe this helps?

kcmshell5 --list | grep power

powerdevilactivitiesconfig - Per-Activity Power Management
powerdevilglobalconfig - Advanced Power Management Settings
powerdevilprofilesconfig - Energy Saving

kcmshell5 powerdevilprofilesconfig

Edit: I would also look at this DPMS

https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling

Is this on a laptop?

No, desktop

These are my DPMS settings.

xset q

DPMS (Energy Star):
  Standby: 600    Suspend: 900    Off: 1200
  DPMS is Enabled
  Monitor is On