Mobile devices not connecting to wifi hotspot on eOS Gnome

Hi,

I am having trouble connecting my mobile devices (android phone and ipad) to the hotspot created in Gnome settings. None of the devices are getting connected to the hotspot when created from gnome settings (even if I create without a password). After a bit of Googling, I tried these:

  1. I used nm-connection-editor to create a new hotspot, but after around 10 seconds the hotspot gets turned off by itself.

  2. I am using linux-wifi-hotspot (AUR package), which seems to work in terms of connection, but the wifi speed I am getting is horrible (10 mbps on a 100 mbps connection, where as in fedora live session, creating hotspot from gnome settings I am getting 60 mbps on connected devices)

I tried this with latest linux, linux-zen and lts kernel. Any help is appreciated. (I am more of a novice user and am not sure what information should be given, but I am attaching neofetch output and AUR packages list nonetheless. )


Neofetch


Output of pacman -Qqm

Why would you use code tags for regular text?
Do you want us to “work” for reading about your issue :wink: :sweat_smile:
Just wondering.

1 Like

Edited the post. (was a silly mistake)

3 Likes

fwiw :wink: :sweat_smile:

I’ve really gotta read more thoroughly.

why use linux-wifi-hotspot
it is easy to set wifi hotspot from terminal

have you tried setting it up with hostapd dnsmasq iptables
from terminal ?