Missing symbols on azerty thinkpad keyboard

I can’t type the symbols less than < or greater than >.

keymapper available in AUR (https://github.com/houmain/keymapper) can be used to customize the keyboard. I’d like to map

<  to alt+w
>  to alt+x

How would you do that in a minimal way?

Here what I’m trying,
First wrote With an editor a file named keymapper.cong which contains:

alt{w} >> <
alt{x} >> >

saved it in :
then from a terminal:

[jeanpat@T430 ~]$ keymapper
Invalid key 'alt' in line 1
Loading configuration failed

Try Meta instead of Alt. Still reading, BRB :smiley:

Ignore me - AltLeft is what you need.

# define some more aliases
  Alt   = AltLeft
  AltGr = AltRight
  Win   = Meta

And… :drum: I cannot get it to work.

Still have some problem. The keymapper.conf file was modified as follow:

# define some more aliases
  Alt   = AltLeft
  AltGr = AltRight
  Win   = Meta

# Mapping on thinkpad T430 azerty keyboard

Alt{w} >> <
Alt{x} >> >

Then from a terminal:

$ systemctl start keymapperd
[jeanpat@T430 ~]$ keymapper
Invalid key 'w' in line 8
Loading configuration failed

As I said I can’t get it to work, I tried a two line config from the github page - it loads OK, but doesn’t do anything.

I can give you a config for interception tools that would give you the characters on taping Control and Alt - would that help? Am at work, it would be later this evening when I get home.

Other options are key-mapper (note the “-” it is not the same program) and xkeysnail (but think xkeysnail is not for wayland) and espanso.

With espanso you would setup a key trigger sequence, when it is typed it is replaced by another sequence or phrase e.g.:

- trigger: "#,"
  replace: "<"

Wayland support is ongoing meaning if you are using wayland it will need compiling.