Mirror.jingk.ai gives error 404 when attempting update

I get this error when I try to update my system:

error: failed retrieving file ‘endeavouros-mirrorlist-4.4.2-1-any.pkg.tar.zst.sig’ from mirror.jingk.ai : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

This happens using yay or pacman. I’ve tried updating my mirrors and forcing a database refresh, and nothing changes. I can access the mirror fine via a broswer, so I don’t understand why it gives a 404 error when attempting the update.

1 Like

Can you access the directory holding the package database file? Is the database file present?

Yes and yes.

Sorry, I didn’t mean the database file, I meant the package file.

I don’t know why I’m not just looking myself… give me a mo.


The file is in the directory index but returns a 404, which indicates the file is missing on disk. This would normally imply an issue with the mirror, in which case the next step would be to contact the mirror maintainer and let them know there’s an issue:



Thanks for your help. It looks like the mirror will be down for a while, as the maintainer needs to rehome the server. What’s the easiest way to blacklist that mirror so I can avoid this error?

Just remove the server from your local mirrorlist file.


Done, and everything works now. Thanks!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.