Minor issues after update to GNOME 42

Hi everyone, I use Endeavour OS as a daily driver on a ThinkPad machine W540 with Gnome. What i notice after update to Gnome 42 is:

  • after every shutdown or reboot Bluetooth need to be enable… :frowning: Is very inconvenient because i use a mouse which is connected trough the Bluetooth
  • now finger print need to used twice to login in gnome
    Notice: before to make this update everything it was fine.

you only need to “enable” the service… so it will get enable on boot …

1 Like

needs more info… as I do not think fingerprint is used without user set up before ?

It is “enabled”

Welcome to the forums!!

When i put my fingerprint to login in my account, sometimes need to reintroduce twice time my fingerprint, and is not a reader error of my fingerprint because it show’s like it will login…but after 3-4 seconds it show 's me GDM login with my name and after I swipe second time the system log me in to the desktop environment.

yea i do understand but you do some setup to be able to use it or not?
And give:
systemctl status bluetooth

could be you mean that you need to “enable” your mouse to work ? and not Bluetooth itself?
This would be that case as long as you do not set it to auto connect…
https://aur.archlinux.org/packages/bluetooth-autoconnect
is a helper to that but can be done also manually…

And I forget to say welcome at the forum :enos_flag:

@joekamprad I’ve read this a few times. I believe it’s a gnome bug currently. I’d expect it fixed in the .1 release

“bluetooth-autoconnect” It did not work

https://wiki.archlinux.org/title/Bluetooth#Auto_power-on_after_boot/resume

Edit: Gnome 42.1 point release isn’t due out until about 2 weeks from now April 23rd, if there’s no additional delays of course, so any bugs will likely be around for about 2 weeks. A bit frustrating to say the least, but not a deal-breaker of course, just something to know.

1 Like

yea never tried that…
and the code also is looking way to complex for such a simple thing:

But I do omit to use BT for everything other than audio … i can check as far as I remember Logitech MX Master 3 has also BT?

@fbodymechanic I was wondering if BT will be able to connect without any Manager app in use… i remember trying that with my headset and it was able to auto-connect after setting it up… without any intervention or manager installed…

The bluetooth bug is very common with Arch users I’ve seen, so my guess and hope is that by Gnome 42.1 point release, this will be resolved hopefully.

i mean i know that Gnome BT implementation itself was always having a lot of issues… but BT itself can be handled without it… or you could use Blueman or Blueberry.

Or use the BT cli itself with bluetoothctl and set configs manually in config files.

Welcome aboard the EOS forums.

The problem persists, after each restart or standby mode of the laptop, you have to manually turn on Bluetooth every time. Just out of curiosity to see if there is a problem with Gnome, I decided to install Ubuntu 22.04 LTS on a different SSD and all I can say is that everything was fine in terms of Bluetooth.

I’m really happy that the file selection window now has previews of images

It was a terrifying experience trying to upload pictures from a huge list without a preview

Edit: looks like I spoke too soon, it’s back to the no preview window that keeps expanding to fullscreen size

Finally I sorted the problem…:slight_smile:
I edit this file /etc/bluetooth/main.conf

[Policy]
AutoEnable=true

This thread can be closed. Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.