Messed up with efi directory

I had three 3 OS installed on my laptop (windows, eos, manjaro).
when i deleted manjaro (first deleting the manjaro partition then its respective efi directory) and booted up. I landed on grub rescue.


currently im booting up by

set boot(hd0,gpt4)
set prefix(hd0,gpt4)/boot/grub
insmod normal
normal

i have tried the grub install and stuff
need help

1 Like

You may be using an EFI boot variable which points to the deleted Manjaro Grub, instead of your EndeavourOS Grub. Boot to your BIOS and see if you are able to re-order the boot priority so EndeavourOS is first, or change the boot order from user space with efibootmgr.

i reorderd boot priority to eos first using efibootmgr but it still doesnt work

Could you post the output of the following commands?

Copy the terminal output as text, paste into your reply, highlight it and press Ctrl-E to format.

sudo parted -l

sudo blkid

efibootmgr

cat /etc/fstab

sudo parted -l

Model: SK hynix BC711 HFM512GD3JX013N (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI System Partition          boot, esp
 2      274MB   290MB  16.8MB               Microsoft reserved partition  msftres
 3      292MB   129GB  129GB   ntfs         Basic data partition          msftdata
 4      129GB   216GB  86.7GB  ext4         endeavouros
 5      216GB   511GB  295GB   ntfs         Basic data partition          msftdata
 6      511GB   512GB  857MB   ntfs                                       hidden, diag

Model: Unknown (unknown)
Disk /dev/zram0: 7614MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system     Flags
 1      0.00B  7614MB  7614MB  linux-swap(v1)

sudo blkid

/dev/nvme0n1p5: LABEL="New Volume" BLOCK_SIZE="512" UUID="B05EDF335EDEF158" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7ffa9c14-b3b8-40de-96d1-747de202c5f1"
/dev/nvme0n1p3: LABEL="Windows" BLOCK_SIZE="512" UUID="E8BAE52ABAE4F5CA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ed4d1c03-6912-4b3a-9e14-4e76077decc8"
/dev/nvme0n1p1: LABEL_FATBOOT="SYSTEM" LABEL="SYSTEM" UUID="C868-0792" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c"
/dev/nvme0n1p6: BLOCK_SIZE="512" UUID="A204FEC504FE9C0B" TYPE="ntfs" PARTUUID="448fa163-e4bc-4f56-b956-d1d3b11ac0fa"
/dev/nvme0n1p4: LABEL="endeavouros" UUID="6664693e-b23e-41b8-a5db-2380a9a370fe" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="endeavouros" PARTUUID="8237334f-aab0-4c5e-b789-288b8bad2394"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="7700b94b-e52c-49b4-8fc6-e5a0a14d6fdb"
/dev/zram0: LABEL="zram0" UUID="09bf19ca-0446-49bc-8b40-7123ca5ffa90" TYPE="swap"

efibootmgr

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0003,9999
Boot0000* Windows Boot Manager	HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)/\EFI\Microsoft\Boot\bootmgfw.efi57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0001* Internal Hard Disk	PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,AC-E4-2E-00-25-14-35-4B)/HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)0000424f
Boot0002* endeavouros	HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)/\EFI\endeavouros\grubx64.efi
Boot0003* Internal Hard Disk	PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,AC-E4-2E-00-25-14-35-4B)/HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)0000424f
Boot0004* rEFInd Boot Manager	HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)/\EFI\refind\refind_x64.efi
Boot0006* Manjaro	HD(1,GPT,cd38b726-dcf6-4d45-a1a9-7d17dd4b0e5c,0x800,0x82000)/\EFI\Manjaro\grubx64.efi
Boot9999* USB Drive (UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)0000424f

bat /etc/fstab

───────┬─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       β”‚ File: /etc/fstab
───────┼─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   β”‚ # /etc/fstab: static file system information.
   2   β”‚ #
   3   β”‚ # Use 'blkid' to print the universally unique identifier for a device; this may
   4   β”‚ # be used with UUID= as a more robust way to name devices that works even if
   5   β”‚ # disks are added and removed. See fstab(5).
   6   β”‚ #
   7   β”‚ # <file system>             <mount point>  <type>  <options>  <dump>  <pass>
   8   β”‚ UUID=C868-0792                            /boot/efi      vfat    fmask=0137,dmask=0027 0 2
   9   β”‚ UUID=6664693e-b23e-41b8-a5db-2380a9a370fe /              ext4    noatime    0 1
  10   β”‚ tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
───────┴─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────

1 Like

Thanks for the outputs!

At a glance, nothing out of the ordinary jumps out. It seems ok.

Was using Grub Customizer part of the β€œstuff” you did, by any chance?
If so, we would need to take some steps to restore your Grub.

If not, maybe worth trying to reinstall the grub’s efi bootloader binary again and regenerate the grub.cfg:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=endeavouros

and

sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

this worked thanks

1 Like

You are welcome! Glad you got it working!

:enos: :wave:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.