Memory Requirement in Atlantis release

It seems in the latest release, you must have at least 2.4 GiB of memory to install:


This seems to be a fairly arbitary limitation, what’s the point of it? This is a VM so I can bump the memory size, just curious.

The memory size has been set because of downloading the packages requires a certain amount of memory or it will cause it to fail to install. As it’s fetching the packages it needs a certain size.

1 Like

we can remove that but the fact is that online installs needs at least 2.4GB of RAM.

3 Likes

I see, thanks. What changed to add this requirement in Atlantis, though? IIRC it wasn’t there in the last release.

1 Like

Joe can correct me if I’m wrong.

I think it is related to the calamares feature we are using now: install a lot of packages in one pacman call instead of installing each package separately with pacman.
Calamares is providing this feature, and I don’t know how exactly they have implemented it, but it seems to consume more RAM than before. That’s why we set the limit that will be checked in the beginning, otherwise the install could just fail later because of too small RAM.

3 Likes

I see.

I think we could use the old version as a fallback if you have less than 2.4 GB ram instead of the installer erroring out.

May could be possible to have swap on the ISO… not sure if possible but worth a test.

i do just test zram what seems to work (kindof) I am not sure how exactly it does work at all as it does not show up as swap on glances or using free command… But I can install in VM with only 2GB RAM setup and installing a huge amount of packages… like plasma i3 and printer stuff all together…

Nah :wink:
I just done the same install without zram enabled and it works too… on VM with 2GB RAM set…
I would say the testings on that were not even and it could be simply an issue on some VMs…

It should; I use zram and it shows as swap. I don’t think you set it up successfully.

free -h
               total        used        free      shared  buff/cache   available
Mem:            23Gi       3.6Gi        14Gi       1.4Gi       4.9Gi        17Gi
Swap:          1.0Gi          0B       1.0Gi
Stagger_Lee:lsblk
NAME     MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sda        8:0    0 465.8G  0 disk  
├─sda1     8:1    0    50G  0 part  /
└─sda2     8:2    0   375G  0 part  /home
sdb        8:16   0   3.6T  0 disk  
└─sdb1     8:17   0   3.6T  0 part  
  └─sdb1 253:0    0   3.6T  0 crypt /mnt/encrypted_sdb1
sr0       11:0    1  1024M  0 rom   
zram0    254:0    0     1G  0 disk  [SWAP]
1 Like

looks more like the issue is to use stuff like that on archiso boot.

1 Like

but what would be needed to setup as a minimal setup? Archwiki do say nothing and README from development do say only the config is needed to have at least something like so:

/etc/systemd/zram-generator.conf
[zram0]
zram-size = ram / 2

it should get loaded automatic on bootup…

I’ve never used zram-generator, I set up my zram manually.

Did you check the github readme page for zram-generator?

1 Like

yes it say nothing is needed only the config needs to be present and holding one section.
Ah seems to work now… i do simply use empty section with [zram0] in config… :wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.