Mc contaminates my bash history

With commands like below, they look like the equivalent commands for what I did.

PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }‘pwd>&9;kill -STOP $$’

bind -x ‘“\e+”:“echo $BASH_VERSINFO:$READLINE_POINT >&11”’

bind -x ‘“\e_”:“mc_print_command_buffer”’

mc_print_command_buffer () { printf “%s\n” “$READLINE_LINE” >&11; }

Started happening like a month ago, happens every time I open midnight commander, I don’t do much just open a few files. I have never changed any settings for mc, everything is on default.

After reading this a few times I can’t make sense, sorry if you where clear and I missed it but what is the actual issue?

After I use midnight commander, I see these kinds of commands in my bash history.

OKAY i’m putting it togeather now, I would go through the midnight commander documentation to try solve this as it has quite an extensvie right up

can;t seem to find the site I just read but here is the himepage fir this program
https://midnight-commander.org/
I will keep looking for a bit as I remember something specific to this

I just hope someone had this issue, I don’t even know what to search for in google, tried a few things but no luck.

1 Like

downgrading fixed it, looks like it’s a bug

downgrading didn’t fix it, added this to my bashrc export HISTCONTROL="ignorespace:erasedups" erasedups isn’t needed, maybe ignoreboth works too

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.