LXQT ..just installed and everything that can go wrong, happened

I am taken a back… thought lxqt will be simple and stable… but just by messing with gui setting, i screwed the whole damn thing … what a chrismas gift.

Lxqt …just installed along side of win7 (but maybe some mistake, now win7 is no longer bootable).
Did some getting use by changing time, date… all those minor gui setting… dual screen…
Unity screen works, extended mode not working… suddenly the whole computer went into frozen, mouse not working, keyboard not working… …force restarted
After restarted, launchbar gone… it did pops out once… then no more.
Changed from ssdm to lx…something , reboot to take effect.
Rebooted again, now now matter how manytime i tried, i just can’t login gui anymore.
However i can login tty2. I thought to try $sudo passwd root to reset password even though unlikely… (since i can login terminal). Tried reset password, but still can’t login gui.

What went wrong ?

  1. how to salvate the gui login issue ?
  2. is there way to bring back win7 ? these photos reflects what i set during installation.

    kalamares prompted me … hence i went back and changed according to what it prompted.


LXQT is simple and stable. You have installed LXQT using an efi partition. Windows was installed on MBR. The partition is marked /boot/efi it should have been legacy boot. Does this laptop have UEFI? or is it BIOS? You can’t mix the two as far as i know?

3 Likes

Keep in mind, lxqt is very simple but simple in this context doesn’t mean that it is easier to use than some of the more fully featured DEs.

It is simple in the sense that it has less complexity and is lighter-weight as a result. However, that means it lacks some of the features that are present in larger, more complicated DEs. It also means there is also less abstraction from the system which can be a good thing or a bad thing depending on your perspective.

3 Likes

Yes, i have read that before, can’t have both MBR and UEFI…
UEFI only accepts GPT.

I was doing just ask instructed on the dualboot installation thread… but during the installation, the system prompted me to do otherwise… hence i thought… the system should know what i should do… and i didn’t think too much of obeying it… … hence made /boot/efi

BIOS
a. Select unpartitioned space → Create
b. Size → input 32
c. Filesystem → select unformatted
d. Flags → check bios-boot → OK

I think there is no Bios-boot … there is only Boot and legacy-boot to choose.
I think Bios-boot here means legacy-boot.

my computer does not have support for UEFI.

I have manage to get my win7 os back running.
Just in the process of fixing win7, i removed linux os from it. Anyway, i want to reinstall afresh…won’t be trying LXQT, becuase it is very buggy in my first review… the display is a mess… some funny thing appears where it should not… it is too hard to explain in word… anyway… lxqt is no longer a choise.

It’s not buggy! You just don’t understand how to install it and set it up. First you need to understand the difference between BIOS & UEFI. You need to understand the partitioning schemes that are required or can be used because there is some flexibility to some aspects of it. But there are also some requirements depending on if it’s installed on UEFI or BIOS that you have to follow. Lxqt is a desktop so that part is separate. You also have to learn about the settings for that particular desktop because it is different than others.

If you reinstall whatever desktop you choose make sure the /boot partition is msdos and flagged legacy boot.

Edit: Good Luck & Merry Christmas! :grinning:

2 Likes

OP come back in a few days. It is a holiday for most of the team.

3 Likes