LXDE Volume Panel dissapearing after every reboot

Every time I reboot I have to manually add the volume panel back.
The entry seems to even dissapear from the configuration file

Please read this article to provide more information about your problem:

(A friendly intro about our community rules and tips for the forum)

Hello @NoChill ,
Just out of curiosity I’ve set up a test system and your disappearing “Volume Control” Settings was reproduced here.
You are not the only one as several similar cases were reported.
For example here is a 9 year old case: https://bbs.archlinux.org/viewtopic.php?id=174631
I’m not really convinced that the above quackery is a fix. Statistically now it is working far better: no missing icons out of 10 logout / reboot in lxpanel.

  • I added keybord layout, Weather and separators among them to do the trick :joy:.
    Is there a good reason for LXDE? LXQT is less outdated. It’s your decision.

Is this the same issue?


The icon and panel works fine, the issue is that I have to re-add it every time I reboot my machine

I am picking LXDE because I need the most lightweight dekstop environment for this low-end laptop

This loaudspeaker randomly disappeared for me.
@lxpanel --profile LXDE
in autostart

Is there a program called pasystray?

Never mind. I just checked but it doesn’t seem to be installed or any way to get it on EndeavourOS. There should be a similar program or called differently.


sudo pacman -Ss "system tray"

(note the double-quotation marks)

I checked with Slackel which has OpenBox but usually LXDE is paired with OpenBox isn’t it?

Check around /etc/xdg/autostart, might have to create a “dot-desktop” so that something launches while the desktop is starting. I’m only making suggestions. I’ve only used LXDE with Knoppix many months ago and didn’t dare configure anything.

The “/etc/xdg/autostart/pasystray.desktop” for my installation of Slackel looks like this:

[Desktop Entry]
Name=PulseAudio System Tray
Comment=An Applet for PulseAudio
Keywords=pulseaudio;tray;system tray;applet;volume

re @mnrvovrfc and thank @NoChill
Having installed cbatticon + pasystray + volumeicon
I removed the original Volume Control and it seems to work ( no Russian roulette ).
NoChill, you’ve solved the problem.

1 Like

im gonna be honest i got annoyed and reinstalled eos with LXQT
i actually did try volwheel on startup before and it worked fine however it was rather laggy for some odd reason

My primary system is Mabox which isn’t a resource hungry distro either.
If there is a workaround for a malfunctioning thing then you’d better fix it rather to jump into an unknown Desktop Environment.
I only tested your original problem.
I was happy with this pasystray solution. I don’t call off any DE if it’s not too fussy to use.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.