Lutris does not work together with Anaconda from AUR

Games didn’t start, until I removed Anaconda.
The normal version of Anaconda does not have this problem for me.
Just wanted to share, in case someone experienced a similar problem.

Apparently, Lutris uses python scripts that created errors when executed by python installed from Anaconda from AUR. Anaconda installed the normal way is somehow not used by Lutris.

This was only working until I rebooted. Any ideas?
I assume that it doesn’t work, because Lutris uses the Anaconda version of python.
In the lutris bash:

$ which python

Without you sharing any of the actual errors you are receiving, it is going to be hard for anyone to help you.

That being said, is there a reason you are using anaconda and a one-off python version instead of the system versions?

I use anaconda for other projects.
The error is simply the game not opening at all. Nothing happening.
When I tried installing a new game, I got:

Fatal Python error: init_import_size: Failed to import the site module
TypeError: 'type' object is not subscriptable

I assume that the problem would be solved, if I could change the $PATH for Lutris. However, I don’t know how to do this.

You have manually installed a version of python at a non-standard location which is fine. However, by changing your path to make it your default python, you are no longer using the system python which is probably breaking dependency management for system-wide python apps.

The way most people handle this is to use the system version of python as normal for running installed apps. When you do Python development or have specialized Python projects you should do those in a pyenv or something similar. This allows only those projects to use the manually installed versions of python. It also allows you to have different versions and configs per project.

If you are committed to continuing to handle Python the way you have been, you probably need to make sure all the required python libraries/modules are available to Lutris.

use the system version of python as normal for running installed apps

That’s the solution, I was thinking about, too. But how can I find out, where anaconda made the setting for the PATH? It’s not in .bashrc.

What is the output of these commands?

echo $PATH
grep PATH ~/.* 2>/dev/null 

I solved it by inserting export PATH="[...]" into my .bashrc.
Thanks for your help! :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.