LTS does not boot properly

I thought I had this beat, but no! I’ve edited loader.conf so 6.6.12-1-lts is default as in:

[jerry@jerry-inspiron3847 ~]$ cat /efi/loader/loader.conf
default 2dc7698043ad441d93183dae3e4e43cb-6.6.12-1-lts.conf
timeout 5
console-mode auto
reboot-for-bitlocker 1

But upon boot it goes to black screen and sits; a quick (1 sec) push of power it turns off (no other way works). Upon power on I have to F12 at the Dell logo, I get a blue bios type window with “UEFI OS” highlighted, press enter, I get the black screen screen with all kernels available: lts, 6.6.7-arch-1 and -arch3, and all the fallbacks. LTS is at the top and highlighted but no small arrow to the side; I let it go and it boots into lts.

A small but irritating problem. Why do I have to F12 and UEFI OS? Here is inxi -Fxxc0z: https://0x0.st/H0nx.txt
Thanks to all.

Try installing r8168-lts

Thanks for getting back. But no change after installing that.

Uninstall xf86-video-intel

Uninstalled, no change.

Wait. I think I am misunderstanding the problem here.

What is the actual issue you are trying to fix?

If I reboot, like after running yay and a reboot is recommended, I can’t walk away and let it go itself or else I’ll come back to a black screen that I can’t get out of, no tty or REISUB, only power off. I have to wait for the Dell logo and F12, then press enter at "UEFI OS’ bios type screen; only then does it boot into LTS.

That sounds like your bios is booting the wrong device or uefi entry

What does sudo efibootmgr show?

BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003,0000,0001,0002
Boot0000* P0: ST1000DM003-1CH162 BBS(17,0x0)
Boot0001* WD My Passport 26261028 BBS(18,0x0)
Boot0002* P4: HL-DT-ST DVD+/-RW GHB0N BBS(19,0x0)
Boot0003* UEFI OS HD(3,GPT,e5833c6c-7df7-af4c-b949-797c260dad67,0x800,0x1f4000)/File(\EFI\BOOT\BOOTX64.EFI)

Run sudo bootctl install

Here it is. Reboot?
sudo bootctl install
Copied “/usr/lib/systemd/boot/efi/systemd-bootx64.efi” to “/efi/EFI/systemd/systemd-bootx64.efi”.
Copied “/usr/lib/systemd/boot/efi/systemd-bootx64.efi” to “/efi/EFI/BOOT/BOOTX64.EFI”.
:warning: Mount point ‘/efi’ which backs the random seed file is world accessible, which is a security hole! :warning:
:warning: Random seed file ‘/efi/loader/random-seed’ is world accessible, which is a security hole! :warning:
Random seed file /efi/loader/random-seed successfully refreshed (32 bytes).
Created EFI boot entry “Linux Boot Manager”.

Run sudo efibootmgr again now

sudo efibootmgr
[sudo] password for jerry:
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0004,0003,0000,0001,0002
Boot0000* P0: ST1000DM003-1CH162 BBS(17,0x0)
Boot0001* WD My Passport 26261028 BBS(18,0x0)
Boot0002* P4: HL-DT-ST DVD+/-RW GHB0N BBS(19,0x0)
Boot0003* UEFI OS HD(3,GPT,e5833c6c-7df7-af4c-b949-797c260dad67,0x800,0x1f4000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot0004* Linux Boot Manager HD(3,GPT,e5833c6c-7df7-af4c-b949-797c260dad67,0x800,0x1f4000)/File(\EFI\systemd\systemd-bootx64.efi)
[jerry@jerry-inspiron3847 ~]$

That looks better. Try rebooting

Did not work, but a new option showed up on what I’m calling the "UEFI OS’ bios type screen. It now shows Linux Boot Manager and UEFI OS. It only showed UEFI OS before. Linux Boot Manager was highlighted, I chose that.

Edit: and it booted into LTS.

Linux boot manager is systemd-boot anything you are seeing before that is your bios

Ok, not sure what to do with that.

You need to go into the BIOS and set UEFI as the default.

In BIOS 1st Boot Device is “UEFI : Linux Boot Manager” but still doesn’t boot properly. But I’m calling it quits now. You’ve been very helpful and considerate and I learned some. If you have anything more I’ll see it tomorrow, if not no worries. Thanks again.