Looking for drivers for my a wireless adapter

Dear all,


I have a semi-old workstation machin where I would like to install Endeavour OS. However, it can only connect to the internet through an Ethernet cable and does not have a Wireless chip inside that sees WIFI networks.

I have bought a TP-Link Mini Wireless N USB Adapter (TL-WN823N) but I wasn’t able to compile the drivers that TP-Link provides, their technical support replied that their drivers only support an older kernel than the one I am trying to use.

If I’m not mistaken Endeavour OS currently uses kernel 5.18, but the available driver for TL-WN823N v3 supports up to kernel 4.9.60.

I have managed to connect to my wifi in Debian running from a USB key following these instructions, which to me it means that it should be possible also in Arch.

I have done some research and have found this page: https://michaelheap.com/tp-link-tl-wn823n-on-arch-linux/, but I haven’t succeeded to follow those instructions:

❯ git clone https://github.com/Mange/rtl8192eu-linux-driver
❯ cd rtl8192eu-linux-driver
❯ sudo dkms add .
Deprecated feature: REMAKE_INITRD
Error! DKMS tree already contains: rtl8192eu-1.0
You cannot add the same module/version combo more than once.
❯ sudo dkms install rtl8192eu/1.0
Sign command: /usr/lib/modules/5.18.12-arch1-1/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub
Certificate or key are missing, generating self signed certificate for MOK...
Deprecated feature: REMAKE_INITRD

Building module:
Cleaning build area...
'make' all KVER=5.18.12-arch1-1...............................
Signing module /var/lib/dkms/rtl8192eu/1.0/build/8192eu.ko
Cleaning build area...

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /usr/lib/modules/5.18.12-arch1-1/updates/dkms/

I have also tried solutions proposed in this thread, e.g.:

❯ yay -S rtl88xxau-aircrack-dkms-git
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  rtl88xxau-aircrack-dkms-git-r1200.cab4e4e-1

  1 rtl88xxau-aircrack-dkms-git      (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
:: Deleting (1/1): /home/pico/.cache/yay/rtl88xxau-aircrack-dkms-git
:: (1/1) Downloaded PKGBUILD: rtl88xxau-aircrack-dkms-git
  1 rtl88xxau-aircrack-dkms-git      (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
:: (1/1) Parsing SRCINFO: rtl88xxau-aircrack-dkms-git
==> Making package: rtl88xxau-aircrack-dkms-git r1200.cab4e4e-1 (Wed 20 Jul 2022 03:47:08 PM CEST)
==> Retrieving sources...
  -> Cloning rtl88xxau git repo...
Cloning into bare repository '/home/pico/.cache/yay/rtl88xxau-aircrack-dkms-git/rtl88xxau'...
remote: Enumerating objects: 12296, done.
remote: Counting objects: 100% (716/716), done.
remote: Compressing objects: 100% (456/456), done.
remote: Total 12296 (delta 289), reused 613 (delta 245), pack-reused 11580
Receiving objects: 100% (12296/12296), 73.72 MiB | 22.39 MiB/s, done.
Resolving deltas: 100% (8369/8369), done.
  -> Found dkms.conf
==> Validating source files with sha256sums...
    rtl88xxau ... Skipped
    dkms.conf ... Passed
==> Making package: rtl88xxau-aircrack-dkms-git r1200.cab4e4e-1 (Wed 20 Jul 2022 03:47:16 PM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating rtl88xxau git repo...
  -> Found dkms.conf
==> Validating source files with sha256sums...
    rtl88xxau ... Skipped
    dkms.conf ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of rtl88xxau git repo...
Cloning into 'rtl88xxau'...
Switched to a new branch 'makepkg'
==> Starting pkgver()...
==> Updated version: rtl88xxau-aircrack-dkms-git r1201.4ab079f-1
==> Sources are ready.
==> Making package: rtl88xxau-aircrack-dkms-git r1201.4ab079f-1 (Wed 20 Jul 2022 03:47:20 PM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "rtl88xxau-aircrack-dkms-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: rtl88xxau-aircrack-dkms-git r1201.4ab079f-1 (Wed 20 Jul 2022 03:47:27 PM CEST)
==> Cleaning up...
 -> Found git repo: github.com/aircrack-ng/rtl8812au.git
[sudo] password for pico: 
loading packages...
warning: rtl88xxau-aircrack-dkms-git-r1201.4ab079f-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)                  Old Version      New Version      Net Change

rtl88xxau-aircrack-dkms-git  r1201.4ab079f-1  r1201.4ab079f-1    0.00 MiB

Total Installed Size:  50.86 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                               [--------------------------------] 100%
(1/1) checking package integrity                             [--------------------------------] 100%
(1/1) loading package files                                  [--------------------------------] 100%
(1/1) checking for file conflicts                            [--------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Remove upgraded DKMS modules
==> dkms remove --no-depmod rtl88xxau/r1201.4ab079f -k 5.18.12-arch1-1
:: Processing package changes...
(1/1) reinstalling rtl88xxau-aircrack-dkms-git               [--------------------------------] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Install DKMS modules
==> dkms install --no-depmod rtl88xxau/r1201.4ab079f -k 5.18.12-arch1-1
==> depmod 5.18.12-arch1-1
(3/3) Checking which packages need to be rebuilt

But the adapter still doesn’t work. It sees the wifi networks, but it can’t connect to mine.

Any tips? What should I try?

Hardward info

Here’s some information about the machine:

Machine manufacturer: LENOVO
Product name: 30C70009MB
Product version: ThinkStation P330
Processor manufacturer: Intel(R) Corporation
Processor version: Intel(R) Core™ i7-8700 CPU @ 3.20GHz
UDI: Intel(R) Core™ i7-8700 CPU @ 3.20GHz - INTEL
Display Name: Intel(R) Core™ i7-8700 CPU @ 3.20GHz - INTEL
Model: Intel(R) Core™ i7-8700 CPU @ 3.20GHz
Vendor: INTEL
Number of cores: 6
Number of enabled cores: 6
Number of threads: 12
Signature: 906ea
Max speed: 4.600 GHz
Current speed: 3.192 GHz
Features: MMX, EM64T, SSE, SSE2, SSE3, SSSE3,
FMA, PSE, PSE-36, IDA/Turbo boost,
Cache L1: 6 x 32 KB Data, 6 x 32 KB Instruction
Cache L2: 6 x 256 KB Unified
Cache L3: 1 x 12 MB Unified[/QUOTE]


Maybe start by reading this thread: https://bbs.archlinux.org/viewtopic.php?id=277397 from the ArchLinux forum where someone was using the same adapter. It has some info of specific drivers, etc. to make the adapter work.

Thanks, MrToddarama.

I have also found this page in Italian, that has helped: https://www.osside.net/2018/08/tp-link-tl-wn823n-su-arch-linux/

I don’t read Italian but I could graps that I needed to blacklist something:

echo "blacklist rtl8xxxu" > /etc/modprobe.d/rtl8xxxu-blacklist.conf

Thanks, it’s working now!
Cheers, Manuel

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.