Looking for a usbreset program

I need a program to reset a usb connection, given a usb id. In the Debian/Ubuntu world, this is available in the usbutils package as usbreset. I looked for it on EndeavourOS, but cannot find it in Arch or in the AUR.

The usbutils package also provides lsusb, which is one of the most basic tools. I cannot imagine that it is missing on E-OS. What am I missing here?

It’s in the AUR:

3 Likes

You already have lsusb on Arch, it’s part of the usbutils core package. It does not come with the usbreset utility.

1 Like

Shockingly easy. Only searching for usbutils threw me off track.

But after further inspection, it is not the solution. This is even without a manpage and does NOT work with the USB IDs (VID:PID). Probably just Greg-Kroah Hartman’s ten lines of code for this purpose.

I am looking for the usbreset which works with the USB ID (a man page would also be nice). So, the search continues.

1 Like

Welcome to :enos: forums.

Please mark the post that solved your problem as the solution so this post can auto-close after 2 days.

Welcome to the forum @emk2203 :enos: :enos_flag: :tada: :balloon: :partying_face:

So far, not the solution I am looking for. I have to keep searching and keep this open.

It is indeed just that.

There’s no man page, but did you check the instructions at the github page? Skip steps 1 and 2, as you installed from the AUR. You find and use the Bus ID of the USB device:

The bus id wasn’t really what I wanted, since I need to reset a specific device. But I found that I can use the also-installed usbreset-device for this purpose with sudo usbreset-device VID:PID.

Issue at hand solved. Still puzzles me why Arch and E-OS take such a significant deviation from installing just the whole shebang from GKH’s github and be done with it.

At least, a nice systemd service is thrown in to reset after suspend. :+1:

Thanks again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.