Login screen with frame failure

Hello, last night I installed your ISO on my desktop computer, with an optimal result in all installation fields, without any problem.

Except that when I log in, I find a mess on the grub screen and a subsequent and immediate equal on the Login screen, since I uninstalled Xfce4 and Xfc4-goodies and installed LXDE with Openbox, so I had no problem .

All installation in Legacy mode and with MBR partition table, without gpt. I checked the Xorg logs and everything is fine without errors.
INFO

$ cat /etc/default/grub
# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='EndeavourOS'
GRUB_CMDLINE_LINUX_DEFAULT="quiet audit=0 loglevel=3"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires to
# set 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"
GRUB_DISABLE_SUBMENU=y

dmeg → https://pastebin.com/1Afw1Unj

As you can see in this photo, on the right side of the screen there is a white vertical line and the screen fill is missing.

Grateful → @judd

$ cat /etc/lightdm/lightdm.conf
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
# backup-logs = True to move add a .old suffix to old log files when opening new ones
# dbus-service = True if LightDM provides a D-Bus service to control it
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7 # Setting this to a value < 7 implies security issues, see FS#46799
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-check-graphical=false
#log-directory=/var/log/lightdm
run-directory=/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
#backup-logs=true
#dbus-service=true

#
# Seat configuration
#
# Seat configuration is matched against the seat name glob in the section, for example:
# [Seat:*] matches all seats and is applied first.
# [Seat:seat0] matches the seat named "seat0".
# [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
#
# type = Seat type (local, xremote)
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
# xserver-config = Config file to pass to X server
# xserver-layout = Layout to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#greeter-session=example-gtk-gnome
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
#user-session=default
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8

Are you able to read grub menu and DM?

Replacing lightdm with sddm fix the issue for the DM?

Also, out of curiosity, which video driver are you using? Can you give the info from inxi -Fxz please?

Hello, If I can read grub and dm, it happens that I express myself badly before, my apologies.
I will replace it with SDDM
I pass the inxi:

$ inxi -Fxz
System:
  Host: judd Kernel: 5.2.0-arch2-1-ARCH x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: LXDE 0.10.0 Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-880GM-USB3 v: x.x serial: <filter> 
  BIOS: Award v: F8 date: 10/15/2010 
CPU:
  Topology: Dual Core model: AMD Phenom II X2 560 bits: 64 type: MCP 
  arch: K10 rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 13263 
  Speed: 800 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 800 2: 800 
Graphics:
  Device-1: AMD Turks XT [Radeon HD 6670/7670] vendor: Micro-Star MSI 
  driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa tty: N/A 
  OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.2.0-arch2-1-ARCH LLVM 8.0.0) 
  v: 3.3 Mesa 19.1.2 direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.2.0-arch2-1-ARCH 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: ce00 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Linksys WUSB54GC v3 802.11g Adapter [Ralink RT2070L] type: USB 
  driver: rt2800usb bus ID: 3-2:2 
  IF: wlp0s18f2u2 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 44.24 GiB (9.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-001CA0 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 457.43 GiB used: 44.24 GiB (9.7%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 39.9 C gpu: radeon temp: 39 C 
  Fan Speeds (RPM): cpu: 787 fan-1: 2766 fan-3: 0 
  Voltages: 12v: N/A 5v: 3.04 3.3v: N/A vbat: 2.94 
Info:
  Processes: 143 Uptime: 7m Memory: 3.85 GiB used: 650.4 MiB (16.5%) 
  Init: systemd Compilers: gcc: 9.1.0 clang: 8.0.1 Shell: bash v: 5.0.7 
  inxi: 3.0.35 

Then I comment how it goes with ssdm …

Thank you !

@fernandomaroto

When I want to disable lightdm with * sudo systemctl stop lightdm.service * it automatically turns black and I run out of commands to get back to work and I have to reset the computer. I don’t understand what happens … but hey, it’s just cosmetic the screen theme, it’s not worrying at all!
However; After trying out commands, I didn’t have a display-manager and when I re-introduced the EOS pendrive I found myself happily in squid with the function of keeping my partition and it was really like that, I returned to the desktop with everything configured as before. : Excellent work of that function in Calamares
I appreciate and appreciate that !!

En la pantalla de grub, el controlador de video ni siquiera importa porque el kernel aún no se ha cargado.

Si lo desea, puede cambiar la configuración del tema y usar solo 1 fondo de pantalla

por ejemplo, comentar la línea en /etc/default/grub

GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

y agrega
GRUB_BACKGROUND="/usr/share/endeavouros/splash.png"

luego actualice grub
sudo grub-mkconfig -o /boot/grub/grub.cfg

Sobre sddm lo leí mal, no me di cuenta de que el archivo de configuración era lightdm

Si todavía quiere probar, primero debe instalar sudo pacman -S sddm sddm-kcm y luego habilitar sudo systemctl enable -f sddm.
Luego reinicie, ya que esto ya prueba si el grub está funcionando.

De todos modos, este problema es extraño, usted es la primera persona en informar esto, que yo sepa. Quizás sea muy específico con su hardware.

Mi controlador de video lleva las mismas cosas que el tuyo, la única diferencia es que ati siempre se bloquea en mi computadora

Display: x11 server: X.Org 1.20.5 driver: radeon FAILED: ati 
           unloaded: fbdev,modesetting,vesa

Muchas gracias!

I understand, without a doubt, it is a problem with the hardware and the video card itself …

Made the change to sddm and I found the problem with the Live-iso which is the frequency of Hz, the monitor at 1440x900 takes 75.1 Hz and changing to 60.1 Hz changes the resolution and fills the monitor, you understand? There is the problem, but good is the problematic hardware.
I leave you a photo with sddm

I thank you again for taking the time, since I know very well that you don’t have it !!

1 Like

I didn’t know that changing the frequency would impact the resolution this way. Is this what you mean? I’m noobie :slight_smile:

No problem friend. You may not know but you’re one of the people that taught me to use linux as well, considering all your help in antergos forum.

Did you also try changing the grub theme to image? If so, do you get the same issue?

Maybe you can set the frequency in the monitor settings, then.

Exactly that, then upon entering the desktop it is already changed to 60 and you can work. I spend in many Linux distros with this computer …

Yes, but there is no problem with that, that’s fine.

It is good that it was useful for you, I really appreciate it, and I am very happy that you have progressed so much, as you have been doing, keep it up !!!

Thanks again for everything!

1 Like