Login screen renders badly (after update?)

Since yesterday, my XFCE EndeavourOS installation login screen renders in a very weird way.
Function is not otherwise compromised, I can insert my password and log in, after which the system will load and work completely correctly.
I had updated my system and also installed some software before rebooting and encountering this behaviour.

Has anyone experienced something similar?

Screenshot 2020-12-03 at 18.46.10

:scream:

:upside_down_face:

What is your graphics card? Radeon?

Edit: If so you could try changing v-blank settings.

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "off" --create

Then log out and back in.

I have Intel’s integrated graphics, Intel HD 520 on an i3 6100U
Should I try changing v-blank settings?

@ricklinux I tried changing the v-blank settings, but to no avail.
Interestingly enough, the issue does not present itself on the log in screen when I log out, but only when I boot my laptop from off state

Could you post the output of hwinfo --gfxcard or inxi -G?

1 Like

Here are

inxi -G
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel 
           Device-2: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: intel unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.2.3

and

hwinfo --gfxcard
19: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.386]
  Unique ID: _Znp.0P5RvoI0FHC
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Skylake GT2 [HD Graphics 520]"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x1916 "Skylake GT2 [HD Graphics 520]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x1280 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xde000000-0xdeffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 128 (22649 events)
  Module Alias: "pci:v00008086d00001916sv00001043sd00001280bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #19

Please post the output of pacman -Qs xf86-video

This is it!

pacman -Qs xf86-video
local/xf86-video-amdgpu 19.1.0-2 (xorg-drivers)
    X.org amdgpu video driver
local/xf86-video-ati 1:19.1.0-2 (xorg-drivers)
    X.org ati video driver
local/xf86-video-fbdev 0.5.0-2 (xorg-drivers)
    X.org framebuffer video driver
local/xf86-video-intel 1:2.99.917+913+g9236c582-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-vesa 2.5.0-1 (xorg-drivers xorg)
    X.org vesa video driver

Why do you have the ATI and AMDGPU drivers?

I think I may have messed up some time ago when installing a neural network software, I will try to remove them and reboot

This is why i wondered if he had Radeon because this looks like a Radeon issue that i have seen on mine.

2 Likes

Removing those 2 packages (and rebooting) didn’t seem to change the situation

How about:

  lspci -vnn | grep -PA9 'VGA|Display|3D'
lspci -vnn | grep -PA9 'VGA|Display|3D'
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device [1043:1280]
	Flags: bus master, fast devsel, latency 0, IRQ 128
	Memory at de000000 (64-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

What if you uninstall the xf86-video-intel driver and reboot?
But before doing that, make sure you have the EndeavourOS USB installer available, so that you can recover your system in case something happens… :wink:

Edit: Or you could first try with the LTS kernel:
sudo pacman -S linux-lts linux-lts-headers

1 Like

Does he need to create /etc/X11/xorg.conf.d/20-intel-graphics.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TripleBuffer" "true"
   Option      "TearFree"     "true"
   Option      "DRI"          "false"
EndSection
1 Like

Unfortunately this did not sort any effect! :slightly_frowning_face:

Getting a live USB ready and then I will try that!

This page may also have useful info: https://wiki.archlinux.org/index.php/Intel_graphics

1 Like