Login problem after patching

I was running updates and after that I could not logon to my sway “desktop” anymore. Worked fine with i3 and bspwm. Using lightdm.

Today I changed to sddm and now I can login to my sway “desktop” again. I havent testie this more than just replicating the same problem on another laptop aswell.

Well, if you are happy with SDDM, then your problem is solved :slight_smile:

1 Like

Yep agree more of a heads up if anyone else gets the same problem. :slight_smile:

1 Like

But good to know the test machine was a clean install of endeavouros sway edition.
Did system updates and rebooted then nomore sway login.

1 Like

yea if anyone else has the same issue with sway please report !
It could be something we can solve with the power of the community :fist:

1 Like

I would like to test this out. Please correct the steps if I’m wrong.

Steps to reproduce.

  1. Clean install :enos: Sway.
  2. Update the system.

But doesn’t CE’s pull the newest packages from the repo?

1 Like

Yes you are correct. It was an slightly older new install witch I updated.

So to make shure there is an issue (at least for me) I redownloaded the latest iso and reinstalled.

And as you said it pull the latest packages witch make it so I cant login even for the first time.

This Git Issue

Not me but the same

1 Like

Do you get a black screen when you try to log in to Sway? and then you’re returned to the login screen again?

Yes, that is correct.

AFAIK it lightdm bug … if like lightdm + no want change ? You can TTY type sway .

I no have lightdm/any for sway … ( :pray: no fix but might help ) I sure fix come soon

LightDM seems to be broken with Sway.

Agree that lightdm seems broke. B̶u̶t̶ ̶n̶o̶t̶ ̶a̶s̶ ̶s̶i̶m̶p̶l̶e̶ ̶a̶s̶ ̶@̶S̶h̶j̶i̶m̶ ̶p̶u̶t̶s̶ ̶i̶t̶ ̶a̶s̶ ̶l̶i̶g̶h̶t̶d̶m̶ ̶w̶i̶l̶l̶ ̶b̶l̶o̶c̶k̶ ̶t̶t̶y̶.̶ ̶I̶f̶ ̶y̶o̶u̶ ̶d̶o̶n̶t̶ ̶h̶a̶v̶e̶ ̶a̶ ̶n̶o̶n̶e̶ ̶w̶a̶y̶l̶a̶n̶d̶ ̶“̶d̶e̶s̶k̶t̶o̶p̶”̶ ̶i̶n̶s̶t̶a̶l̶l̶e̶d̶ ̶y̶o̶u̶ ̶w̶i̶l̶l̶ ̶p̶r̶o̶b̶a̶b̶l̶y̶ ̶n̶e̶e̶d̶ ̶t̶o̶ ̶u̶s̶b̶ ̶b̶o̶o̶t̶ ̶a̶n̶d̶ ̶c̶h̶r̶o̶o̶t̶.̶

You where correct, just my first laptop that didnt want to go to tty, second test machine did it just fine. My bad, sorry.

At the moment kinda bad user experience if you install only sway edition, but no easy fix.

? You’re saying you can’t switch to TTY with Ctrl+Alt+F2 for example?

There is some ugly workaround to get it working by delaying the startup of sway with lightdm.
(I had to use this nasty trick to get external keyboard and mouse working properly: https://github.com/canonical/lightdm/issues/63#issuecomment-671046962).

Apparently it also helps for the “fallback to lightdm login screen issue”

  1. Create bash script (e.g. /usr/local/bin/start-sway)

# btw, here is also a good place if you also use other DE/WM's next to sway
# and you want to set specific env vars that are only needed for sway / wayland sessions
# e.g. "export MOZ_ENABLE_WAYLAND=1" and things like that...

sleep 2
exec /usr/bin/sway
  1. Make it executable: sudo chmod +x /usr/local/bin/start-sway
  2. Create another wayland session file pointing to the script: /usr/share/wayland-sessions/sway-fix.desktop
[Desktop Entry]
Name=Sway (start-fix)
Comment=An i3-compatible Wayland compositor

That’ll give you an additional option in lightdm:



this login ligthdm access error still persists in EOS Apollo sway community edition… I can prove it. Please consider change display manager to correct it

last check Ly is default sway for EOS . maybe i wrong ?

1 Like

Sorry my bad it is not lightdm you’re right it is Ly display manager which did not let me access as login. I just put off my sway tour for this round.

Thats sad. You could try to install sddm thats what I use atm and it works okey.

1 Like