Loggin in to console

When I start my machine it takes me to the console, not my actual desktop environment.
When I try to sudo pacman -S gnome it tells me sudo command not found.

This installs gnome desktop environment and you don’t want to do that everytime you login. On gnome the default display manager is gdm. Enable it systemctl enable gdm.service and reboot.

Not possible unless you have done something wrong with your system.

The problem persists I start the machine it starts /dev/sda1: recovering journal and it stays there the whole time.

Did you attempt an update and fail in the process?

You should chroot in and finish the update. Or if it lets you, switch to a TTY and do the same ( nmtui if you need wifi).

If nothing else from chroot you can post up system info that could be useful.

What were you doing when this happened?

… i feel like we should remove the “quiet” flag from grub :wink: users would see where it fails …

I know a lot of users do not like the code running on boot but … it will be 23 times easier to catch issues with boot…

What do others think?

On the issue…
Try using su and see if it works… but not having sudo available … does not feel good…

5 Likes

I personally don’t like it quiet.

It makes me feel like a hacker to see the boot cascade. But. . . I’m aware in an odd one lol.

1 Like

Removing “quiet” flag is one of the first few things I do after any fresh install.

I enjoy watching those boot messages.

1 Like

i do have the journal running all the time:


And indeed why should watch a black screen while booting? :nerd_face:

1 Like

I have grown to love journalctl -f :sweat_smile:

I would like to have an interface that shows all processes running through the CPU :rofl:

1 Like

I guess then one would need to blink with the same frequency of the CPU to catch a sight of them?
:thinking:

we are gone offtopic … but yea i would say in a terminal it would look like … grey blur only :wink:

1 Like

Same here.

Mostly i don´t know what it wanna tell me, but i like it very much and too I am with

Just kidding :stuck_out_tongue_winking_eye:

I have always hated it when the boot messages are hidden ala windows. I would like quiet to be disabled by default, but I don’t have to have it either. It has become a habit for me to disable it after a new installation, among other measures.

1 Like

I love the commitment in the comments but could we go back to the issue at hand!

yes back to your issue:
give some more info like:

  1. is this a fresh install or happened after update/changes?
  2. does changing to root with suwork? does pacman command work as root?

Okay

  1. It’s not a fresh install, lately whilst using the machine it reboots itself and takes me out to the login page without any reason.
  2. When I boot into (fallback initramfa) and go to the console I can’t use any useful command sudo, ls, pacman, yay etc

so after install (GNOME) system runs fine but suddenly reboots and the issue arises?
recovering the journal shows that something went wrong already…
So if you can not use TTY you will have to boot a livesystem like the installer iso from USB stick and check system from there to have a working system to start with…

you can also check the drive/s from livesession before chrooting into system:

sudo fsck -p /dev/sdXn

what will check and fix automatically where /dev/sdXn needs to be changed to the drive you want to check.

If it were up to me, I would certainly remove it from the default.

Sure, text scrolling can be annoying, but it takes only a minute to add the quiet option. And those who do not like it and do not know how to add the quiet option are incentivised to learn it, so then they’ll also know how to remove it if something goes wrong. Instead of not knowing it and having to do it for the first time at the moment when other things are going wrong as well…

6 Likes