Locales - got too many

Hi, new install, I thought it had actually hung but it has installed every locale known to man by the looks of it…seeing this on pacman update…
I only want English with French bits…
How do I get rid of all those other weird languages?
Thanks

You can run locale in the terminal and this will show you what you have set for languages. Then you can edit the locale file in /etc/locale.gen and comment out what ever languages you do not want with #. Then save the file and run locale-gen. This will create a new locale.

4 Likes

Did you fix it already or still need help?

hi
I did as rick suggested and that worked but I’d like to purge the unneeded locales to get back the disk space…
I came across localepurge but it looks out of date now…
cheers

1 Like

:+1:

It works but won’t save that much space. Can’t precise how much but i ran the command like 2 or 3 weeks ago.

This is an old but good tutorial how to use it in case you still want execute it.
you can start watching at 1min 40sec

1 Like

ok I was a bit worried by comments here https://aur.archlinux.org/packages/localepurge/
ie out-of-date/legacy BUT I decided to take the plunge
yay -S localepurge
result

Some new locales have appeared on your system:

de.UTF-8 fr.ISO8859-1 fr.UTF-8 jp pl.UTF-8 zh 

They will not be touched until you reconfigure localepurge
with the following command:

    /usr/bin/localepurge-config

localepurge: Disk space freed in /usr/share/locale: 318652 KiB
localepurge: Disk space freed in /usr/share/man: 3020 KiB

Total disk space freed by localepurge: 321672 KiB

Bit weird about those ‘new locales’ invading my system but I can sleep on that one…:grin:

1 Like

Just to inform you, you may get warnings when updating the system like “locale not found” or something like that, because you remove them. These are not errors, just warnings, so don’t worry if they pop up when you update your system

@fernandomaroto I just had a question regarding the installer and locales. I reinstalled Xfce using the newest beta ISO and it installed all locales which makes the install process slow hanging at locales. Doesn’t the installer select a locale according to location you put in when going through the install process? I don’t remember it doing this on the first beta or the stable ISO? Or maybe I just didn’t notice?

Are you using the 15th july iso?
I tested yesterday and i couldn’t replicate this issue, i’ll try again today.
In which process in calamares you noticed this locale hanging?

No this is on the Beta devel-ISO 2019-07-16. It’s hanging at 39% during the install at locales because it loads them all.

I not even have this iso here. You can just in case check if all locale.gen languages are uncomented, if so, this was just a joe’s test.

Just delete this iso. Out of curiosity where did you download this? It’s not in our github nor sourceforge repos.

It’s on the download page. The reason i tried it is because @driver69 had this issue and also was checking out to see if i got the font issue but you already informed us that it was Pango. So i installed it and i had both issues. But i now know about pango and fonts. I fixed it but i guess my question was if the installer is supposed to set the locale based on your location and not install All of them?

ah ok. @Bryanpwo i don’t know how to edit the download page, can you remove the iso endeavouros-devel-2019.07.16-x86_64 please?

Calamares just add the choosen language to the end of locale.gen, without further changes. So my guess this iso has all languages uncommented by default.

That must be it as i know i didn’t have this on the original Beta ISO or the Stable ISO.

I’ll do it in a few hours, I can’t do it from my phone.

1 Like

It’s done, I’ve removed it.

1 Like

Ups I do completely forget to upload a fixed one… should have been the Nvidia enabled ISO, and not this first tryout to fix Asian Font issue.

1 Like