Locale Warning since last update

(gedit:4959): Gtk-WARNING **: 10:44:01.405: Locale not supported by C library.
Using the fallback ‘C’ locale.

This is the warning I get as soon as I create a file (with gedit).
Other than that, if I type

gedit exercise3-1.cpp
two files open. One is named “exercise” and the other one “3-1”. How did that happen?

Locale:

Kann »LC_ALL« nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
LANG=en_GB.UTF-8
LC_CTYPE=“en_GB.UTF-8”
LC_NUMERIC=de_AT.UTF-8
LC_TIME=Default.UTF-8
LC_COLLATE=“en_GB.UTF-8”
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES=“en_GB.UTF-8”
LC_PAPER=de_AT.UTF-8
LC_NAME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION=de_AT.UTF-8
LC_ALL=

I want my system to be in English but there were certain things (metrics, time) that I set to Austrian.

I’m 100% certain that I didn’t get any error/warning messages before the last update.
Is there any way to check my last updates?

Thank you!

How did you set these values?

Given EnOS is a rolling release there’s no such thing as “the last update”.

If it’s installed you can use paclog, or you can look at /var/log/pacman.log.

I had the exact issue and removing ~/.config/plasma-localerc solved it for me, though there could be other reasons. Also check the link below.
https://wiki.archlinux.org/title/Locale#My_system_is_still_using_wrong_language

1 Like

This value does not exist in Arch systems. Probably Ubu-effect… :fearful:

1 Like

Try regenerating your locale:

sudo locale-gen

Does that return any errors?

2 Likes

How did you set these values?

As soon as I installed EndeavourOS, a few questions popped up: Region, language, etc.

I still get the perl: warning: Falling back to the standard locale ("C).

[2022-04-12T14:36:45+0200] [ALPM-SCRIPTLET] perl: warning: Falling back to the standard locale ("C").
[2022-04-12T14:36:47+0200] [ALPM-SCRIPTLET] perl: warning: Setting locale failed.
[2022-04-12T14:36:47+0200] [ALPM-SCRIPTLET] perl: warning: Please check that your locale settings:

Try regenerating your locale:

sudo locale-gen

Does that return any errors?

Nope. No errors…

Then after regenerating your locale, your problem is most likely fixed.

If you run

perl -e 'print "Hi!\n";'

Does that print any errors?