Locale trouble

==> Image generation successful
( 7/11) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "en_DK.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_MEASUREMENT = "en_DK.UTF-8",
        LC_TIME = "en_SE.UTF-8",
        LC_COLLATE = "C",
        LC_NUMERIC = "en_DK.UTF-8",
        LANG = "en_GB.utf8"
    are supported and installed on your system.



/etc/locale.gen (redacted)

#en_AU.UTF-8 UTF-8  
#en_AU ISO-8859-1  
#en_BW.UTF-8 UTF-8  
#en_BW ISO-8859-1  
#en_CA.UTF-8 UTF-8  
#en_CA ISO-8859-1  
en_DK.UTF-8 UTF-8  
#en_DK ISO-8859-1  
en_GB.UTF-8 UTF-8  
#en_GB ISO-8859-1  
#en_HK.UTF-8 UTF-8  
#en_HK ISO-8859-1  
#en_IE.UTF-8 UTF-8  
#en_IE ISO-8859-1  
#en_IE@euro ISO-8859-15  
#en_IL UTF-8  
#en_IN UTF-8  
#en_NG UTF-8  
#en_NZ.UTF-8 UTF-8  
#en_NZ ISO-8859-1  
#en_PH.UTF-8 UTF-8  
#en_PH ISO-8859-1  
#en_SC.UTF-8 UTF-8  
#en_SG.UTF-8 UTF-8  
#en_SG ISO-8859-1  
en_US.UTF-8 UTF-8  
#en_US ISO-8859-1  
#en_ZA.UTF-8 UTF-8  
#en_ZA ISO-8859-1  
#en_ZM UTF-8  
#en_ZW.UTF-8 UTF-8  
#en_ZW ISO-8859-1
 [philo@Spooner ~]$ sudo locale-gen 
[sudo] password for philo: 
Generating locales...
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_US.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
Generation complete.

I’m trying to get ISO standards (8601 dates, and metric, A4 paper) with Britsh English, but I live in Florida.

first thing i see (but should not be the trouble) you have en_GB.UTF-8 en_DK.UTF-8 double entries in locale.gen.

what shows:

locale -a
[philo@Spooner ~]$ locale -a

Is en_SE.UTF-8 in your /etc/locale.gen?

localectl set-locale LANG=en_US.UTF-8
where LANG can be one of:

  • LANG

i do not understand where the first error output is from, so i do not get what is the issue exactly…

No, I don’t see it listed, thus I assume if I insert it, without the files for it to refer to then I think it will not work. Isn’t that right? It seems like if we’re going to insert new files then it would make the most sense to create an en_ISO.UTF-8. In the past it was always en_DK, then that stopped working, I’m guessing the people in Denmark did not like the fact that they don’t actually use ISO and wanted it to use whatever stupid format they use… but I’m not sure about that.


does this even exist?

So the question is what exactly< is the first error coming from image creation from what was pulling out that error? and where do you set LC_TIME = "en_SE.UTF-8" ?

I remember having a user with a similar issue before try using a locale mixed out of to …

I am in fact danish and when we use english we use ISO - so I guess that is the reason for having the en_DK format.

I have seen a lot of locale issues on the Manjaro forum and it seems the common thing is KDE.

I don’t know it this is the case here (KDE I mean) - but if you have defines in locale.conf which has not been been set in locale.gen and subsequently generated by locale-gen then you get messages like the OT.

Maybe I am confusing myself but I think KDE has locales which has no definition in locale.gen.

While it is not necessary to encapsulate the setting in locale.conf - the only environment I have noted using double quotes(") in locale.conf - is KDE and it is the only environment I have seen writing non-standard locales to locale.conf.

1 Like

this sounds legit to me, as the locale is not at the system itself at all and does not show up on system commands themself

Thanks for your insights about English in Denmark. My ancestors come from Denmark, as a matter of fact my famliy name is Frederiksen. I find it interesting to know that you do use ISO with Engish.

I just looked and as a matter of fact, I do see that in KDE I have the Time set to en_SE, which is not in fact in locale.gen. In locale.conf I have LC_TIME=en_DK.UTF-8. If I try to set KDE to Time=en_DK I don’t get ISO… So, it seems you’re correct, it’s a KDE bug. That said, the most elegant solution would be to have a en_ISO locale for time, measurement and numbers.

As I see it your locale.gen has several lines which repeats the generation.

The explanation for that could be the Calamares installer adding the locales to the end of locale.gen instead of modifying the actual line.

I suggest you remove the doubled entries in locale.gen.

If you want to avoid issues with non-existing locales I suggest you modify your locale.conf and change the reference from the system-invalid locales to system-valid locales.

Ah, I never looked all the down to the bottom of the file before! I’ll delete the doubled entries. I don’t have any system-invalide locales in /ect/locale.conf, so that shouldn’t be an issue.

is this point ?