Locale settings often are messed up after major Plasma updates

I don’t know how it is with you, but very often, not always, when KDE releases a new major version update, my locale settings are messed up and it is the same issue over and over again. I know how to fix it, I mean it comes up so often I know the command by heart, which isn’t a good thing in this case. :wink:
I have had this issue on Plasma for some time now and on different hardware. Do you have a permanent solution or am I one of the rare users who encounter this issue almost on a regular schedule?

EDIT: It is this issue https://bbs.archlinux.org/viewtopic.php?id=262047

Are you using more than one locale, or different formats from your chosen locale? Which is your chosen locale?

I’m using British English and en_GB.UTF-8 for all formats, and never have any problems.

The output of locale -a for me is:


1 Like

If I change my locale via KDE System Settings, for some reason LC_ALL becomes blank, which causes startup failure on some applications. This also breaks os-prober for some reason :man_shrugging:

No, I use Dutch nl_NL.UTF-8

It has to do with some Plasma updates and after restoring it, it’s all fine. It’s a bit annoying.
I don’t know if you remember, but a couple of months ago I had this issue not being able to change the name whilst downloading a PDF, which you also solved and turned out to be a Plasma thing as well? That bug returned after the latest Plasma update.


Did you try the steps in this post again?

Are all your language and format settings only Dutch?

I fixed it, but to be honest I don’t like how Plasma handles major updates. I will not ditch it though, but I find the overriding settings after an update a bit annoying.

Yes, but when the issue arises, there’s a typo in one or more of the lines. It shows up after an update as:


I tend to use a major Plasma update as an excuse to do a reinstall, partly to see what the new defaults are…

Sounds like a :bug: Maybe some of the other :netherlands: people here can see if they can replicate?

The other alternative is to declare yourself a loyal subject of Her Britannic Majesty :crown: :uk: and switch to en_GB.UTF-8 :wink:

1 Like

This can might help over this issue:-


The reason might be b/w default language and custom chosen language, I guess…

That is a different issue, in my case, there is just a stupid typo in the settings of locale that comes back once in a while.