Loading Wi-Fi&BT modules via dracut

Hi there!

I have a T2 Mac running the T2 iso from their GitHub. Everything is working, except for loading modules. Specifically; brcmfmac. I can get Wi-Fi to work via modprobe brcmfmac after every reboot, but I seem unable to get it to load at boot via dracut.

I have tried editing /etc/dracut.conf.d/wifi.conf

#add_dracutmodules+=“ brcmfmac hci_bcm4377 “
#add_modules[…]
#add_dracutdrivers[…]
#add_drivers[…]

Afterwards running #dracut-rebuild, no dice.

I am somewhat familiar with eos and completely unfamiliar with dracut. I’m sure I’m missing something by just following the man pages. Thanks for any insight

If those are kernel modules you can use:

add_drivers+=" brcmfmac hci_bcm4377 "

Be sure not to put a # at the beginning of the line as in your examples above.

If you need those modules loaded early use force_drivers instead.

Thanks for the reply!

I have tried doing add_drivers without the comment out #. Ran dracut-rebuild, immediately reboot and Wi-Fi never comes back up until I manually load them when I run modprobe brcmfmac as well as modprobe hci_bcm4377.

Am I perhaps missing a step after dracut-rebuild?

Did you verify that the modules were added?

As in modinfo?

This is the output for the specific card I need drivers for:

[X@mbp161 ~]$ modinfo brcmfmac | grep 4387
firmware: brcm/brcmfmac4387c2-pcie.clm_blob
firmware: brcm/brcmfmac4387c2-pcie.bin

I do not see brcmfmac in the output of dracut-rebuild though.

lsinitrd | grep cm

Yes it is loaded there. Do you need the full output?

If both the modules you need are there and it still isn’t working, you could try force_drivers instead.

No dice.

force_drivers+=“ brcmfmac hci_bcm4377 ”

sudo dracut-rebuild
[…] dracut: dracut module ‘brcmfmac’ cannot be found or installed

Reboot; nada.

I wonder if it is a firmware issue, not kernel modules.

I’m not sure, modprobe works every time to get Wi-Fi to run.

Can I add modprobe to a start up just to quick and dirty get it working.

In slack it’s /etc/rc.local. Not sure what the equivalent is for eos?

Create a systemd service and enable it.

Thanks!

I have made so many changes, I broke modprobe working. Hah. :sweat_smile:

Going to try reinstalling. Also, the live iso Wi-Fi works great. Is there anyway copy over those settings and files?