Live ISO: Network constantly gets connected/disconnected

i initially posted this here: Eric Adams made a video on the net-installer

i can’t reliably rely on netinstall due to this consistent connect/disconnect of a wired internet. other live iso works fine. Using calamares with debugging enabled, i can see message related to this network instability shows up each times the New Connection notif pops-up:

this is happening on the new live iso, as well as the older one. Rebuilding the ISO does not do anything to remedy this.

Could you tell us which distro’s with an online installer do work and could you give us your hardware info?

We had bug reports about the ISO connecting to faulty mirrors, but you’re the first one with a network connection problem, making me think this could be hardware related.

ArcoLinuxB/D, ArchLabs, Antergos, Manjaro Architect, Debian, if it counts, arch’s iso. Its not just about able to use netinstall, the live iso should not have this constant network disconnect/connect issue. Any other live iso installer has no problems using the net including antiX, MX-Linux, Solus, openSuse etc.

System:    Host: endaevour Kernel: 5.6.4-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 
           Distro: EndeavourOS 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8H61-M LX3 PLUS R2.0 v: Rev X.0x 
           serial: <superuser/root required> UEFI: American Megatrends v: 1106 date: 02/25/2014 
CPU:       Topology: Dual Core model: Intel Pentium G2020 bits: 64 type: MCP arch: Ivy Bridge 
           rev: 9 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11602 
           Speed: 1600 MHz min/max: 1600/2900 MHz Core speeds (MHz): 1: 1600 2: 1600 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics vendor: ASUSTeK 
           driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0152 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.6.4-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK P8 series driver: r8169 v: kernel port: e000 bus ID: 03:00.0 
           chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 30:85:a9:43:0f:37 
Drives:    Local Storage: total: 3.64 TiB used: 2.01 TiB (55.1%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: Z3408K79 rev: CC29 scheme: GPT 
           ID-2: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: Z4Z73MDP rev: CC26 scheme: GPT 
Partition: ID-1: / size: 180.73 GiB used: 7.46 GiB (4.1%) fs: ext4 dev: /dev/sdb6 
           ID-2: swap-1 size: 14.88 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 196 Uptime: 14m Memory: 7.23 GiB used: 1.99 GiB (27.5%) Init: systemd 
           v: 245 Compilers: gcc: 9.3.0 clang: N/A Shell: bash v: 5.0.16 
           running in: xfce4-terminal inxi: 3.0.38

As I said before, it’s the first time we had a report of this bug, 99% of our users, several vloggers and bloggers do have a stable network connection on the ISO.

It’s not that I don’t believe you, but we’re happy to look into it and if we don’t find the issue, please don’t be mad, apparently, you’ve found an abundance of choices for your hardware to get into Linux. And that’s what counts. :wink: :heart:


same hardware …
Realtek hardware is known to have issues with drivers and firmware under Linux.

im not implying any feelings of being mad here, im just stating the issue coz this is new for as well and only happens with this ISO and to clearly send the message that this is not an install/mirror issue like what people experience on Antergos before. the Live ISO itself is connecting/disconnecting the network as seen on the screenshot counter. I can install arch manually fine, but do not have idea about the live ISO other than building it from prebuilt instructions.

are you saying, if i use Manjaro ISO right now, i will have the same problem… coz i just did and it works ok now, it worked ok before.

its not even the same issue since the guy is reporting a dropped connection issue, like 30minutes or so.

Joe is not implying anything, hold your horses, we’re trying to help you and like you, we are also touching in the dark.

i do only try to research if there is a known issue with this device or driver under Archbased… simple to see if there is a workaround to get the issue solved.

I believe Joe is simply trying to gather information in search of a solution. Sometimes the multicultural nature of this forum, and others, lends itself to communication glitches. People of different backgrounds and native languages all writing in English will occasionally come across as abrupt when that is not what is meant at all. Joe was not writing off your problem, but rather sharing what info he has so far. If there is a final solution to what you are experiencing (or a workaround) someone on this forum will be able to look at everything gathered and find it. There is a lot of brain power and knowledge here :grin:

Be Blessed

4 Likes

RTL8111/8168/8411 is shown as hardware and driver in use is called r8169

i find a package also on the repo:

https://www.archlinux.org/packages/community/x86_64/r8168/
Last Updated: 2020-04-14 19:11 UTC

and also AUR build:
https://aur.archlinux.org/packages/r8169aspm-dkms/

I would need some logs to see if there was something failing for the device, and this is how we do work.
We need the community to report issues to help with testing solutions and then we can integrate this into ISO.

This is what we got shipped with current kernel:
Bildschirmfoto_2020-04-15_14-07-54

Could be it was selecting wrong driver as there is no 8111/8168/8411 only r8169

So to test you could install r8168 driver and load the modules:

sudo pacman -S r8168
sudo rmmod r8169
sudo modprobe r8168

and dmesg | grep r8169 and after change dmesg | grep r8168 should show info.

1 Like

I agree there are multiple instances where the r8169 does not work correctly with that chip and use r8168 is answer.

thanks. whatever is done to the new iso (may iso release) has fixed my network issue. so this topic can be close.

ok, there doesn’t seem to be a way for thread starter to close issue…