Live ISO boots fine but no wifi no network devices in preinstallation? (SOLVED)

I have EOS on both my Acer and MSI laptops all installed fine and running fine . (SOLVED)

But I got a new laptop Asus vivobook 14X (M7400QE) today and wanted to install EOS.

The ISO boots fine. But the there is no wifi at all? There is only bluetooth? says
“no network devices available”?

edit: when I connect a LAN cable I can get internet via LAN. But no wifi adapter or anything still.
Even in settings I cannot see anything says “wifi”

Update : I installed EOS Neo 22.12 via internet via my LAN line . After an hour or so of just updating and installing apps I suddenly saw “wifi” adapter appeared miraculously. Not sure what did it as I was just installing apps.

What adapter is it?

inxi -Na

$ inxi -Na
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2723 class-ID: 0280

I installed using LAN line internet. The wifi adapter suddenly appeared after a few reboots and updates post-installation… Not sure what happened, because I didn’t intentionally install any special drivers from arch/aur or anything? But it seems to be all OK now…thanks.

iwlwifi should automatically load. Hard to say what update may have made the difference. You could check the pacman log in /var/log/pacman.log I wouldn’t worry to much about it as it is working now.

Ya, thanks anyway. It didnt load pre install and the live disk had no wifi adapter…even post install there was none…then after a few updates and reboots it suddenly appeared. So all good now anyway. Thanks. Was panicking a bit before because EOS installed fine on my other two laptops lol.

Ya… I’m not sure the reason. Sometimes these hardware act weird for unknown reasons. Sometimes if you shut it down for few minutes and then they work. It can be due to settings in Windows sometimes if dual booting also.